poj 1416 Shredding Company

/*
Shredding Company
Time Limit: 1000MS		Memory Limit: 10000K
Total Submissions: 3326		Accepted: 1889

Description
You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics.

1.The shredder takes as input a target number and a sheet of paper with a number written on it.

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50.

Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50


There are also three special rules :

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.

For example, if the target number is 100 and the number on the sheet of paper is also 100, then

the paper is not cut.

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number.

Input
The input consists of several test cases, each on one line, as follows :

tl num1
t2 num2
...
tn numn
0 0

Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.

Output
For each test case in the input, the corresponding output takes one of the following three types :

sum part1 part2 ...
rejected
error

In the first type, partj and sum have the following meaning :

1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +...

Each number should be separated by one space.
The message error is printed if it is not possible to make any combination, and rejected if there is
more than one possible combination.
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.

Sample Input

50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output

43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected

Source
Japan 2002 Kanazawa

2803:碎纸机

    查看
    提交
    统计
    提示
    提问

总时间限制:
    1000ms
内存限制:
    65536kB

描述
    你现在负责设计一种新式的碎纸机。一般的碎纸机会把纸切成小片,变得难以阅读。而你设计的新式的碎纸机有以下的特点:

    1.每次切割之前,先要给定碎纸机一个目标数,而且在每张被送入碎纸机的纸片上也需要包含一个数。
    2.碎纸机切出的每个纸片上都包括一个数。
    3.要求切出的每个纸片上的数的和要不大于目标数而且与目标数最接近。

    举一个例子,如下图,假设目标数是50,输入纸片上的数是12346。碎纸机会把纸片切成4块,分别包含1,2,34和6。这样这些数的和是43 (= 1 + 2 + 34 + 6),这是所有的分割方式中,不超过50,而又最接近50的分割方式。又比如,分割成1,23,4和6是不正确的,因为这样的总和是34 (= 1 + 23 + 4 + 6),比刚才得到的结果43小。分割成12,34和6也是不正确的,因为这时的总和是52 (= 12 + 34 + 6),超过了50。

    还有三个特别的规则:
    1.如果目标数和输入纸片上的数相同,那么纸片不进行切割。
    2.如果不论怎样切割,分割得到的纸片上数的和都大于目标数,那么打印机显示错误信息。
    3.如果有多种不同的切割方式可以得到相同的最优结果。那么打印机显示拒绝服务信息。比如,如果目标数是15,输入纸片上的数是111,那么有两种不同的方式可以得到最优解,分别是切割成1和11或者切割成11和1,在这种情况下,打印机会显示拒绝服务信息。


    为了设计这样的一个碎纸机,你需要先写一个简单的程序模拟这个打印机的工作。给定两个数,第一个是目标数,第二个是输入纸片上的数,你需要给出碎纸机对纸片的分割方式。
输入
    输入包括多组数据,每一组包括一行。每行上包括两个正整数,分别表示目标数和输入纸片上的数。已知输入保证:两个数都不会以0开头,而且两个数至多都只包含6个数字。

    输入的最后一行包括两个0,这行表示输入的结束。
输出
    对每一组输入数据,输出相应的输出。有三种不同的输出结果:

    sum part1 part2 ...
    rejected
    error

    第一种结果表示:
    1.每一个partj是切割得到的纸片上的一个数。partj的顺序和输入纸片上原始数中数字出现的次序一致。
    2.sum是切割得到的纸片上的数的和,也就是说:sum = part1 + part2 +...
    第一种结果中相邻的两个数之间用一个空格隔开。

    如果不论怎样切割,分割得到的纸片上数的和都大于目标数,那么打印“error”。
    如果有多种不同的切割方式可以得到相同的最优结果,那么打印“rejected”。 



*/

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cmath>
using namespace std;
    int t = 0;
    char num[8] = {0};
    int cut[8] = {0};

int main()
{
    while(true)
    {
        scanf("%d%s", &t, num);
        if(t == 0 || num == 0) break;
        memset(cut,0,sizeof(cut));
        bool mark = 0, reje = 0;
        int sol[8] = {0}, soln = 0, nows = 0, doub = 0;
        for(int k = 0; k < pow(2.0, int(strlen(num) - 1)); ++k)
        {
            //printf("%d\n", k);
            int div[8] = {0};
            int nc = 0;
            cut[0] = 1;
            int sum_ = 0;
            for(int i = 1; i < strlen(num); ++i)
            {
                cut[i] = (k >> (i - 1)) & 1;
            }
                int ti = 0;
                int s_ = 0;
            for(int i = strlen(num) - 1; i >= 0; --i)
            {
                if(cut[i] == 0)
                {
                    s_ += (num[i] - '0') * pow(10.0, ti);
                    ti++;
                }
                else
                {
                    s_ += (num[i] - '0') * pow(10.0, ti);
                    div[nc] = s_;
                    nc++;
                    sum_ += s_;
                    ti = 0;
                    s_ = 0;
                }
            }
            //printf("sum%d\n", sum_);
            //printf("nows%d\n", nows);
            if(sum_ <= t && nows <= sum_)
            {
                if(nows == sum_) doub = 1;
                else
                {nows = sum_;
                doub = 0;
                mark = 1;
                    soln = nc;
                    for(int i = 0; i < nc; ++i)
                    sol[i] = div[i];}
            }
        }
        if(!mark) printf("error\n");
        else if(doub) printf("rejected\n");
        else
        {
            printf("%d", nows);
            for(int i = soln - 1; i >= 0; --i)
            {
                printf(" %d", sol[i]);
            }
            printf("\n");
        }
    }
    return 0;
}

你可能感兴趣的:(poj,cpp)