poj2823 Sliding Window

/*
Sliding Window
Time Limit: 12000MS		Memory Limit: 65536K
Total Submissions: 32999		Accepted: 9795
Case Time Limit: 5000MS
Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position	Minimum value	Maximum value
[1  3  -1] -3  5  3  6  7 	-1	3
 1 [3  -1  -3] 5  3  6  7 	-3	3
 1  3 [-1  -3  5] 3  6  7 	-3	5
 1  3  -1 [-3  5  3] 6  7 	-3	5
 1  3  -1  -3 [5  3  6] 7 	3	6
 1  3  -1  -3  5 [3  6  7]	3	7
Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 
Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 
Sample Input

8 3
1 3 -1 -3 5 3 6 7
Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
Source

POJ Monthly--2006.04.28, Ikki
*/

#include <cstdio>
#include <cstdlib>
#define max_size 1000001

int w[max_size] = {0};

class poi
{
	public:
		int num;
		int position;
};

class m_queue
{
	public:
		poi i_q[max_size];//递增序列 用来求最小值
		poi d_q[max_size];//递减序列 用来求最大值 
		int i_front, i_back;
		int d_front, d_back;
		
		m_queue()
		{
			i_front = 0;
			d_front = 0;
			i_back = -1;
			d_back = -1;
		}
	
		void mqi_insert(poi temp_p)
		{
			int temp_n = temp_p.num;
			int temp_cur = i_back + 1;
			for (int i = i_back; i >= i_front; --i)
			{
				if (temp_n <= i_q[i].num) temp_cur = i;
				else break;
			}
			i_back = temp_cur;
			i_q[i_back] = temp_p; 
		}
		
		void mqd_insert(poi temp_p)
		{
			int temp_n = temp_p.num;
			int temp_cur = d_back + 1;
			for (int i = d_back; i >= d_front; --i)
			{
				if (temp_n >= d_q[i].num) temp_cur = i;
				else break;
			}
			d_back = temp_cur;
			d_q[d_back] = temp_p;
		}
		
		int get_i(int p, int k_)
		{
			int temp = 0;
			for(int i = i_front; i <= i_back; ++i)
			{
				if (p - i_q[i].position + 1<= k_)
				{
					temp = i_q[i].num;
					i_front = i;//去头 
					break;
				}
			}
			return temp;
		}
		
		int get_d(int p, int k_)
		{
			int temp = 0;
			for(int i = d_front; i <= d_back; ++i)
			{
				if (p - d_q[i].position + 1<= k_)
				{
					temp = d_q[i].num;
					d_front = i;//去头 
					break;
				}
			}
			return temp;
		}
};

m_queue mq;

int main()
{
	int n = 0, k = 0;
	scanf("%d%d", &n, &k);
	for(int i = 0; i < n; ++i)
	{
		scanf("%d", &w[i]);
	}
	for(int i = 0; i < n; ++i)
	{ 
		poi temp_point;
		temp_point.num = w[i];
		temp_point.position = i;
		mq.mqi_insert(temp_point);
		if (i >= k - 1)
		{
			printf("%d", mq.get_i(i, k));
			if (i != n - 1) printf(" ");
		}
	}
			printf("\n");
	
	for(int i = 0; i < n; ++i)
	{
		poi temp_point;
		temp_point.num = w[i];
		temp_point.position = i;
		mq.mqd_insert(temp_point);
		if (i >= k - 1)
		{
			printf("%d", mq.get_d(i, k));
			if (i != n - 1) printf(" ");
		}
		
	}
			printf("\n");
	return 0;
}

你可能感兴趣的:(poj)