单臂路由实现不同vlan间的通信

拓扑图如下:

 

首先在交换机上创建两个vlan,vlan10,和vlan20,将下面的两个终端分别加入vlan10,和vlan20,配置如下:

Switch>enable
Switch#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname s1
s1(config)#line console 0
s1(config-line)#logging synchronous 日志同步
s1(config-line)#exit
s1(config)#int f0/1
s1(config-if)#switchport mode access 接入模式
s1(config-if)#switchport access vlan 10加入vlan10
s1(config-if)#int f0/2
s1(config-if)#switchport mode access 接入模式
s1(config-if)#switchport access vlan 20加入vlan20
s1(config-if)#end

我们show一下vlan

s1#show vlan



VLAN Name                             Status    Ports


---- -------------------------------- --------- -------------------------------


1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6


                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10


                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14


                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18


                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22


                                                Fa0/23, Fa0/24, Gig1/1, Gig1/2


10   VLAN0010                         active    Fa0/1
20   VLAN0020                         active    Fa0/2


1002 fddi-default                     act/unsup


1003 token-ring-default               act/unsup


1004 fddinet-default                  act/unsup


1005 trnet-default                    act/unsup



VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2


---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------


1    enet  100001     1500  -      -      -        -    -        0      0


10   enet  100010     1500  -      -      -        -    -        0      0


20   enet  100020     1500  -      -      -        -    -        0      0


1002 fddi  101002     1500  -      -      -        -    -        0      0   


1003 tr    101003     1500  -      -      -        -    -        0      0   


1004 fdnet 101004     1500  -      -      -        ieee -        0      0   


1005 trnet 101005     1500  -      -      -        ibm  -        0      0   



Remote SPAN VLANs


------------------------------------------------------------------------------




Primary Secondary Type              Ports

将交换机的f0/24口改为trunk模式

s1#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
s1(config)#int f0/24
s1(config-if)#switchport mode trunk
我们查看下接口:

s1#show interfaces f0/24 switchport


Name: Fa0/24


Switchport: Enabled


Administrative Mode: trunk


Operational Mode: down


Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q


Negotiation of Trunking: On


Access Mode VLAN: 1 (default)


Trunking Native Mode VLAN: 1 (default)


Voice VLAN: none


Administrative private-vlan host-association: none


Administrative private-vlan mapping: none


Administrative private-vlan trunk native VLAN: none


Administrative private-vlan trunk encapsulation: dot1q


Administrative private-vlan trunk normal VLANs: none


Administrative private-vlan trunk private VLANs: none


Operational private-vlan: none


Trunking VLANs Enabled: ALL


Pruning VLANs Enabled: 2-1001


Capture Mode Disabled


Capture VLANs Allowed: ALL


Protected: false


Appliance trust: none

进入路由器f0/0接口并打开接口

Router>enable
Router#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname r1
r1(config)#line console 0
r1(config-line)#logging synchronous
r1(config-line)#exit
r1(config)#int f0/0
r1(config-if)#no shutdown

我们再次进入交换机查看f0/24口:

s1#show interfaces f0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none

回到路由器,配置子接口:

r1(config)#int f0/0.10

%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up
r1(config-subif)#
r1(config-subif)#encapsulation dot1Q 10 为子接口封装802.1q协议,承载vlan10的流量
r1(config-subif)#ip address 192.168.1.254 255.255.255.0

r1(config-subif)#int f0/0.20

%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up
r1(config-subif)#encapsulation dot1Q 20
r1(config-subif)#ip address 192.168.2.254 255.255.255.0

r1(config-subif)#end

 

查看下路由器路由表:

r1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/0.10
C    192.168.2.0/24 is directly connected, FastEthernet0/0.20

配置终端:

1.1:

IP Address......................: 192.168.1.1
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.1.254

2.1:

IP Address......................: 192.168.2.1
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.2.254

 

测试:192.168.2.1    ping其他设备:

PC>ping 192.168.2.254



Pinging 192.168.2.254 with 32 bytes of data:



Reply from 192.168.2.254: bytes=32 time=17ms TTL=255


Reply from 192.168.2.254: bytes=32 time=8ms TTL=255


Reply from 192.168.2.254: bytes=32 time=8ms TTL=255


Reply from 192.168.2.254: bytes=32 time=9ms TTL=255



Ping statistics for 192.168.2.254:


    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),


Approximate round trip times in milli-seconds:


    Minimum = 8ms, Maximum = 17ms, Average = 10ms



PC>ping 192.168.1.254



Pinging 192.168.1.254 with 32 bytes of data:



Reply from 192.168.1.254: bytes=32 time=8ms TTL=255


Reply from 192.168.1.254: bytes=32 time=8ms TTL=255


Reply from 192.168.1.254: bytes=32 time=10ms TTL=255


Reply from 192.168.1.254: bytes=32 time=2ms TTL=255



Ping statistics for 192.168.1.254:


    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),


Approximate round trip times in milli-seconds:


    Minimum = 2ms, Maximum = 10ms, Average = 7ms



PC>ping 192.168.1.1



Pinging 192.168.1.1 with 32 bytes of data:



Request timed out.


Reply from 192.168.1.1: bytes=32 time=18ms TTL=127


Reply from 192.168.1.1: bytes=32 time=18ms TTL=127


Reply from 192.168.1.1: bytes=32 time=16ms TTL=127



Ping statistics for 192.168.1.1:


    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),


Approximate round trip times in milli-seconds:


    Minimum = 16ms, Maximum = 18ms, Average = 17ms

你可能感兴趣的:(职场,Cisco,休闲,单臂路由)