routerA:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial0/1
ip address 192.1.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
!
router ospf 10
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.1.1.0 0.0.0.255 area 0
routerB:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Serial0/2
ip address 192.1.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.1.1.1 201 broadcast
frame-relay map ip 192.1.1.3 201 broadcast
!
router ospf 10
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 192.1.1.0 0.0.0.255 area 0
routerC:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Serial0/3
ip address 192.1.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.1.1.1 301 broadcast
frame-relay map ip 192.1.1.2 301 broadcast
!
router ospf 10
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 192.1.1.0 0.0.0.255 area 0
看一下邻居关系都是FULL状态
routerA#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:01:32 192.1.1.3 Serial0/1
2.2.2.2 0 FULL/ - 00:01:55 192.1.1.2 Serial0/1
routerB#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:01:51 192.1.1.1 Serial0/2
routerC#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:01:56 192.1.1.1 Serial0/3
看一下路由表,在点到多点模式下,会自动形成32位主机路由
routerA#sh ip route
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 192.1.1.2, 00:06:10, Serial0/1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 192.1.1.3, 00:06:10, Serial0/1
192.1.1.0/24 is variably subnetted, 3 subnets, 2 masks
C 192.1.1.0/24 is directly connected, Serial0/1
O 192.1.1.2/32 [110/64] via 192.1.1.2, 00:06:10, Serial0/1
O 192.1.1.3/32 [110/64] via 192.1.1.3, 00:06:10, Serial0/1
routerB#sh ip rou
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 192.1.1.1, 00:05:56, Serial0/2
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/129] via 192.1.1.1, 00:05:56, Serial0/2
192.1.1.0/24 is variably subnetted, 3 subnets, 2 masks
C 192.1.1.0/24 is directly connected, Serial0/2
O 192.1.1.1/32 [110/64] via 192.1.1.1, 00:05:56, Serial0/2
O 192.1.1.3/32 [110/128] via 192.1.1.1, 00:05:56, Serial0/2
routerC#sh ip rou
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 192.1.1.1, 00:06:05, Serial0/3
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/129] via 192.1.1.1, 00:06:05, Serial0/3
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
192.1.1.0/24 is variably subnetted, 3 subnets, 2 masks
C 192.1.1.0/24 is directly connected, Serial0/3
O 192.1.1.1/32 [110/64] via 192.1.1.1, 00:06:05, Serial0/3
O 192.1.1.2/32 [110/128] via 192.1.1.1, 00:06:05, Serial0/3