实验思路:
1.
dr的选举,更高的优先级,或者使对手丧失选举的资格(dr优先级=0)
2.
虚链路不能在骨干区域使用!
3.
配置特殊区域,聚合路由可以减少路由表规模以及抑制部分lsa
4.
合理使用默认路由,使得全网络互通
5.
利用ospf的策略,过滤掉路由
6.
验证
<RT0>dis cu
#
sysname RT0
#
router id 0.0.0.1
#
interface Serial1/0/0
link-protocol ppp
ip address 192.168.1.10 255.255.255.0
#
interface Serial1/0/1
link-protocol ppp
ip address 192.168.2.10 255.255.255.0
#
interface Serial1/0/2
link-protocol ppp
ip address 192.168.3.10 255.255.255.0
ospf authentication-mode simple plain 123
#
ospf 1
area 0.0.0.0
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255
network 192.168.3.0 0.0.0.255
#
Return
<RT1>dis cu
#
sysname RT1
#
router id 1.1.1.1
#
interface Ethernet1/0/0
ip address 14.14.14.1 255.255.255.0
#
interface Serial1/0/0
link-protocol ppp
ip address 192.168.1.1 255.255.255.0
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 192.168.1.0 0.0.0.255
area 0.0.0.1
network 14.14.14.0 0.0.0.255
nssa no-summary
#
Return
<RT2>dis cu
#
sysname RT2
#
router id 2.2.2.2
#
interface Ethernet1/0/0
ip address 26.26.26.2 255.255.255.0
#
interface Serial1/0/0
link-protocol ppp
ip address 192.168.2.2 255.255.255.0
#
interface NULL0
#
ospf 1
area 0.0.0.0
network 192.168.2.0 0.0.0.255
area 0.0.0.2
authentication-mode simple plain 123
network 26.26.26.0 0.0.0.255
nssa no-summary
#
Return
<RT3>dis cu
#
sysname RT3
#
router id 3.3.3.3
#
interface Ethernet1/0/0
ip address 37.37.37.3 255.255.255.0
#
interface Serial1/0/0
link-protocol ppp
ip address 192.168.3.3 255.255.255.0
ospf authentication-mode simple plain 123
#
ospf 1
area 0.0.0.0
network 192.168.3.0 0.0.0.255
area 0.0.0.3
network 37.37.37.0 0.0.0.255
vlink-peer 7.7.7.7
#
Return
<RT4>dis cu
#
sysname RT4
#
router id 4.4.4.4
#
interface Ethernet1/0/0
ip address 14.14.14.4 255.255.255.0
ospf dr-priority 0
#
interface Ethernet1/0/1
ip address 45.45.45.4 255.255.255.0
#
ospf 1
asbr-summary 50.1.0.0 255.255.240.0
import-route rip 1
area 0.0.0.1
network 14.14.14.0 0.0.0.255
nssa
#
rip 1
undo summary
default-route originate
version 2
network 45.0.0.0
#
Return
<RT5>dis cu
#
sysname RT5
#
router id 5.5.5.5
#
interface Ethernet1/0/0
ip address 45.45.45.5 255.255.255.0
#
interface NULL0
#
interface LoopBack1
ip address 50.1.1.1 255.255.255.0
#
interface LoopBack2
ip address 50.1.2.1 255.255.255.0
#
interface LoopBack3
ip address 50.1.3.1 255.255.255.0
#
interface LoopBack4
ip address 50.1.4.1 255.255.255.0
#
rip 1
undo summary
version 2
network 45.0.0.0
import-route direct
#
Return
<RT6>dis cu
#
sysname RT6
#
router id 6.6.6.6
#
interface Ethernet1/0/0
ip address 26.26.26.6 255.255.255.0
ospf dr-priority 0
#
interface NULL0
#
interface LoopBack1
ip address 60.1.1.1 255.255.255.0
#
interface LoopBack2
ip address 60.1.2.1 255.255.255.0
#
interface LoopBack3
ip address 60.1.3.1 255.255.255.0
#
interface LoopBack4
ip address 60.1.4.1 255.255.255.0
#
ospf 1
asbr-summary 60.1.0.0 255.255.240.0
import-route direct
area 0.0.0.2
authentication-mode simple plain 123
network 26.26.26.0 0.0.0.255
nssa
#
Return
<RT7>dis cu
#
sysname RT7
#
router id 7.7.7.7
#
acl number 2000
rule 5 deny source 70.1.1.0 0.0.0.255
rule 10 permit
#
interface Ethernet1/0/0
ip address 37.37.37.7 255.255.255.0
ospf dr-priority 0
#
interface Ethernet1/0/1
ip address 78.78.78.7 255.255.255.0
#
interface NULL0
#
interface LoopBack1
ip address 70.1.1.1 255.255.255.0
#
ospf 1
filter-policy 2000 export
import-route direct
area 0.0.0.3
network 37.37.37.0 0.0.0.255
vlink-peer 3.3.3.3
area 0.0.0.4
abr-summary 80.1.0.0 255.255.0.0
network 78.78.78.0 0.0.0.255
#
Return
<RT8>dis cu
#
sysname RT8
#
router id 8.8.8.8
#
interface Ethernet1/0/0
ip address 78.78.78.8 255.255.255.0
#
interface NULL0
#
interface LoopBack1
ip address 80.1.1.1 255.255.255.0
#
interface LoopBack2
ip address 80.1.2.1 255.255.255.0
#
interface LoopBack3
ip address 80.1.3.1 255.255.255.0
#
interface LoopBack4
ip address 80.1.4.1 255.255.255.0
#
ospf 1
area 0.0.0.4
network 78.78.78.0 0.0.0.255
network 80.1.1.0 0.0.0.255
network 80.1.2.0 0.0.0.255
network 80.1.3.0 0.0.0.255
network 80.1.4.0 0.0.0.255
#
return