实验拓扑图:
实验环境:GNS3、C3640
目的是:验证eigrp是否自动实现负载均衡
下面开始做实验
1、为R1配置IP地址
R1>en
R1#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int lo0
R1(config-if)#ip add 1.1.
*Mar 1 00:02:27.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip add 1.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int fa0/0
R1(config-if)#ip add 192.168.20.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int s1
*Mar 1 00:02:57.815: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:02:58.815: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#int s1/0
R1(config-if)#ip add 192.168.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#
2、为R2配置IP地址
R2>en
R2#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int lo0
R2(config-if)#ip add 2.
*Mar 1 00:04:48.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip add 2.2.2.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#int fa0/0
R2(config-if)#ip add 192.168.20.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#int s
*Mar 1 00:05:13.451: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:05:14.451: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#int s1/0
R2(config-if)#ip add 192.168.10.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#
3、对R1进行eigrp的配置
R1(config)#router
R1(config)#router ei
R1(config)#router eigrp 100
R1(config-router)#net
R1(config-router)#network 1.1.1.0 255.255.255.0
R1(config-router)#net
R1(config-router)#network 192.168.10.0
R1(config-router)#net
R1(config-router)#network 192.168.20.0
R1(config-router)#no au
R1(config-router)#no auto-summary
R1(config-router)#
4、对R2进行eigrp的配置
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router ei
R2(config)#router eigrp 100
R2(config-router)#net
R2(config-router)#network 2.2.2.0 255.255.255.0
R2(config-router)#net
R2(config-router)#network 192.168.10.0
R2(config-router)#net
R2(config-router)#network
*Mar 1 00:08:37.311: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.10.1 (Serial1/0) is up: new adjacency
R2(config-router)#network 192.168.20.0
R2(config-router)#no a
R2(config-router)#no a
*Mar 1 00:08:46.511: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.20.1 (FastEthernet0/0) is up: new adjacency
R2(config-router)#no au
R2(config-router)#no auto-summary
R2(config-router)#
在R1上pingR2
R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/59/116 ms
在R1上R1#sho ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 1.1.1.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 2.2.2.0/24, 1 successors, FD is 156160
via 192.168.20.2 (156160/128256), FastEthernet0/0
via 192.168.10.2 (2297856/128256), Serial1/0
P 192.168.10.0/24, 1 successors, FD is 2169856
via Connected, Serial1/0
P 192.168.20.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
可见到达R2中2.2.2.0
继任路由是via 192.168.20.2 (156160/128256), FastEthernet0/0
可靠的继任者是
P 2.2.2.0/24, 1 successors, FD is 156160
via 192.168.10.2 (2297856/128256), Serial1/0
实验结束!
顺便提一建邻的必要条件:
1、收到hello或ACK
2、具有匹配的AD号
3、具有相同的度量(K值)