EIGRP
负载均衡
网络拓扑:
实验目的:
EIGRP
非等价负载均衡
实验步骤:
1.
配置接口及
IP
地址:
a)
R1
的配置:
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface s1/2
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface loopback 0
R1(config-if)#ip add 1.1.1 .1 255.255.255.0
b)
R2
的配置:
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface s1/3
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface s1/2
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2 .2 255.255.255.0
c)
R3
的配置:
R3(config)#interface s1/3
R3(config-if)#ip address 192.168.3.2 255.255.255.0
R3(config-if)#no shutdown
R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3 .3 255.255.255.0
2.
配置
EIGRP
路由
a)
R1
的配置:
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.1.0 0.0.0 .255
R1(config-router)#network 192.168.2.0 0.0.0 .255
R1(config-router)#network 1.1.1 .0 0.0.0.255
b)
R2
的配置:
R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.1.0 0.0.0 .255
R2(config-router)#network 192.168.2.0 0.0.0 .255
R2(config-router)#network 192.168.3.0 0.0.0 .255
R2(config-router)#network 2.2.2 .0 0.0.0 .255
c)
R3
的配置:
R3(config)#router eigrp 100
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.3.0 0.0.0 .255
R3(config-router)#network 3.3.3 .0 0.0.0 .255
3.
查看
R1
的路由:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF , IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0 .0/24 is subnetted, 1 subnets
C 1.1.1 .0 is directly connected, Loopback0
2.0.0 .0/24 is subnetted, 1 subnets
D 2.2.2 .0 [90/156160] via 192.168.2.2, 00:00:39, FastEthernet0/0
3.0.0 .0/24 is subnetted, 1 subnets
D 3.3.3 .0 [90/2300416] via 192.168.2.2, 00:00:06, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial1/2
C 192.168.2.0/24 is directly connected, FastEthernet0/0
D 192.168.3.0/24 [90/2172416] via 192.168.2.2, 00:00:48, FastEthernet0/0
R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID( 1.1.1 .1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 1.1.1
.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 2.2.2
.0/24, 1 successors, FD is 156160
via 192.168.2.2 (156160/128256), FastEthernet0/0
via 192.168.1.2 (2297856/128256), Serial1/2
P 3.3.3
.0/24, 1 successors, FD is 2300416
via 192.168.2.2 (2300416/2297856), FastEthernet0/0
via 192.168.1.2 (2809856/2297856), Serial1/2
P 192.168.1.0/24, 1 successors, FD is 2169856
via Connected, Serial1/2
P 192.168.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.3.0/24, 1 successors, FD is 2172416
via 192.168.2.2 (2172416/2169856), FastEthernet0/0
via 192.168.1.2 (2681856/2169856), Serial1/2
4.
做负载均衡:
a)
R1
上配置:
R1(config)#router eigrp 100
R1(config-router)#variance 3
b)
R2
上配置:
R2(config)#router eigrp 100
R2(config-router)#variance 3
c)
R3
上配置:
R3(config)#router eigrp 100
R3(config-router)#variance 3
然后再在
R1
上查看路由:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF , IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0 .0/24 is subnetted, 1 subnets
C 1.1.1 .0 is directly connected, Loopback0
2.0.0 .0/24 is subnetted, 1 subnets
D 2.2.2 .0 [90/156160] via 192.168.2.2, 00:01:30, FastEthernet0/0
3.0.0 .0/24 is subnetted, 1 subnets
D 3.3.3 .0 [90/2300416] via 192.168.2.2, 00:01:30, FastEthernet0/0
[90/2809856] via 192.168.1.2, 00:01:30, Serial1/2
C 192.168.1.0/24 is directly connected, Serial1/2
C 192.168.2.0/24 is directly connected, FastEthernet0/0
D 192.168.3.0/24 [90/2172416] via 192.168.2.2, 00:01:30,FastEthernet0/0
[90/2681856] via 192.168.1.2, 00:01:30, Serial1/2