1.实验要求
- 1.每台路由器均有32位的换回口
- 2.只有R2和R5相连的两个接口可以收到rip更新包
- 3.eigrp做md5认证
- 4.ospf的A1是nssa区域(暂未)
- 5.ospf的A0做认证
- 6.R2的环回口分配到eigpr,R1和R4的换回口分别分配到相邻的area
- 7.最终保证每个路由器的换回口都能通信
2.实验相关重点
EIGRP的md5认真
OSPF内做虚链路(virtual link)
协议间重分布
3.实验拓扑图
4.实验具体配置
R1:
- R1#sh run
- Building configuration...
- Current configuration : 1336 bytes
- !
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R1
- !
- boot-start-marker
- boot-end-marker
- !
- no aaa new-model
- memory-size iomem 5
- !
- ip cef
- no ip domain lookup
- !
- key chain peter
- key 0
- key-string peter
- !
- interface Loopback0
- ip address 1.1.1.1 255.255.255.255
- ip ospf 1 area 0
- !
- interface FastEthernet0/0
- ip address 192.168.124.1 255.255.255.0
- ip authentication mode eigrp 1 md5
- ip authentication key-chain eigrp 1 peter
- duplex auto
- speed auto
- !
- interface FastEthernet0/1
- ip address 192.168.13.1 255.255.255.0
- ip ospf 1 area 0
- duplex auto
- speed auto
- !
- interface Serial1/0
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/1
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/2
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/3
- no ip address
- shutdown
- serial restart-delay 0
- !
- router eigrp 1
- redistribute ospf 1 metric 100000 100 255 255 1500
- network 192.168.124.0
- no auto-summary
- !
- router ospf 1
- log-adjacency-changes
- redistribute eigrp 1 subnets
- !
- no ip http server
- no ip http secure-server
- !
- control-plane
- !
- line con 0
- exec-timeout 0 0
- logging synchronous
- line aux 0
- line vty 0 4
- login
- !
- end
R2:
- R2#sh run
- Building configuration...
- Current configuration : 1055 bytes
- !
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R2
- !
- boot-start-marker
- boot-end-marker
- !
- no aaa new-model
- memory-size iomem 5
- !
- ip cef
- no ip domain lookup
- !
- key chain peter
- key 0
- key-string peter
- interface Loopback0
- ip address 2.2.2.2 255.255.255.255
- !
- interface FastEthernet0/0
- ip address 192.168.124.2 255.255.255.0
- ip authentication mode eigrp 1 md5
- ip authentication key-chain eigrp 1 peter
- duplex auto
- speed auto
- !
- interface FastEthernet0/1
- ip address 192.168.25.2 255.255.255.0
- duplex auto
- speed auto
- !
- router eigrp 1
- redistribute rip metric 100000 100 255 255 1500
- network 2.0.0.0
- network 192.168.124.0
- no auto-summary
- !
- router rip
- version 2
- redistribute eigrp 1 metric 3
- network 192.168.25.0
- no auto-summary
- !
- no ip http server
- no ip http secure-server
- control-plane
- line con 0
- exec-timeout 0 0
- logging synchronous
- line aux 0
- line vty 0 4
- login
- end
R3:
- R3#sh run
- Building configuration...
- Current configuration : 946 bytes
- !
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R3
- !
- boot-start-marker
- boot-end-marker
- no aaa new-model
- memory-size iomem 5
- !
- ip cef
- no ip domain lookup
- interface Loopback0
- ip address 3.3.3.3 255.255.255.255
- ip ospf 1 area 2
- !
- interface FastEthernet0/0
- ip address 192.168.13.3 255.255.255.0
- ip ospf 1 area 0
- duplex auto
- speed auto
- !
- interface FastEthernet0/1
- ip address 192.168.34.3 255.255.255.0
- ip ospf 1 area 1
- duplex auto
- speed auto
- !
- interface FastEthernet1/0
- ip address 192.168.36.3 255.255.255.0
- ip ospf 1 area 2
- duplex auto
- speed auto
- !
- router ospf 1
- log-adjacency-changes
- area 2 virtual-link 6.6.6.6
- !
- no ip http server
- no ip http secure-server
- control-plane
- line con 0
- exec-timeout 0 0
- logging synchronous
- line aux 0
- line vty 0 4
- login
- !
- end
R4:
- R4#sh run
- *Mar 1 01:41:41.923: %SYS-5-CONFIG_I: Configured from console by console
- R4#sh run
- Building configuration...
- Current configuration : 1254 bytes
- !
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R4
- !
- boot-start-marker
- boot-end-marker
- no aaa new-model
- memory-size iomem 5
- ip cef
- no ip domain lookup
- key chain peter
- key 0
- key-string peter
- interface Loopback0
- ip address 4.4.4.4 255.255.255.255
- ip ospf 1 area 1
- !
- interface FastEthernet0/0
- ip address 192.168.124.4 255.255.255.0
- ip authentication mode eigrp 1 md5
- ip authentication key-chain eigrp 1 peter
- duplex auto
- speed auto
- !
- interface FastEthernet0/1
- ip address 192.168.34.4 255.255.255.0
- ip ospf 1 area 1
- duplex auto
- speed auto
- !
- interface Serial1/0
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/1
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/2
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/3
- no ip address
- shutdown
- serial restart-delay 0
- !
- router eigrp 1
- network 192.168.124.0
- no auto-summary
- !
- router ospf 1
- log-adjacency-changes
- !
- no ip http server
- no ip http secure-server
- control-plane
- line con 0
- exec-timeout 0 0
- logging synchronous
- line aux 0
- line vty 0 4
- login
- !
- !
- end
R5:
- R5#sh run
- Building configuration...
- Current configuration : 1064 bytes
- !
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R5
- !
- boot-start-marker
- boot-end-marker
- !
- !
- no aaa new-model
- memory-size iomem 5
- !
- !
- ip cef
- no ip domain lookup
- interface Loopback0
- ip address 5.5.5.5 255.255.255.255
- !
- interface FastEthernet0/0
- ip address 192.168.25.5 255.255.255.0
- duplex auto
- speed auto
- !
- interface FastEthernet0/1
- no ip address
- shutdown
- duplex auto
- speed auto
- !
- interface Serial1/0
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/1
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/2
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/3
- no ip address
- shutdown
- serial restart-delay 0
- !
- router rip
- version 2
- network 5.0.0.0
- network 192.168.25.0
- no auto-summary
- !
- no ip http server
- no ip http secure-server
- line con 0
- exec-timeout 0 0
- logging synchronous
- line aux 0
- line vty 0 4
- login
- !
- !
- end
R6:
- R6#sh run
- Building configuration...
- Current configuration : 1088 bytes
- !
- version 12.4
- service timestamps debug datetime msec
- service timestamps log datetime msec
- no service password-encryption
- !
- hostname R6
- !
- boot-start-marker
- boot-end-marker
- !
- !
- no aaa new-model
- memory-size iomem 5
- !
- !
- ip cef
- no ip domain lookup
- interface Loopback0
- ip address 6.6.6.6 255.255.255.255
- ip ospf 1 area 3
- !
- interface FastEthernet0/0
- ip address 192.168.36.6 255.255.255.0
- ip ospf 1 area 2
- duplex auto
- speed auto
- !
- interface FastEthernet0/1
- no ip address
- shutdown
- duplex auto
- speed auto
- !
- interface Serial1/0
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/1
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/2
- no ip address
- shutdown
- serial restart-delay 0
- !
- interface Serial1/3
- no ip address
- shutdown
- serial restart-delay 0
- !
- router ospf 1
- log-adjacency-changes
- area 2 virtual-link 3.3.3.3
- !
- no ip http server
- no ip http secure-server
- line con 0
- exec-timeout 0 0
- logging synchronous
- line aux 0
- line vty 0 4
- login
- !
- !
- end