<R1>
<R1>dis curr
#
version 5.20, Release 1808, Standard
#
sysname R1
#
configure-user count 5
#
domain default enable system
#
telnet server enable
#
dar p2p signature-file cfa0:/p2p_default.mtd
#
port-security enable
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple admin
authorization-attribute level 3
service-type telnet
#
interface Aux0
async mode flow
link-protocol ppp
#
interface Ethernet0/0
port link-mode route
ip address 12.1.1.1 255.255.255.0
#
interface Ethernet0/1
port link-mode route
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
interface LoopBack1
ip address 172.16.1.1 255.255.255.255
#
bgp 100
network 172.16.1.1 255.255.255.255
undo synchronization
peer 2.2.2.2 as-number 200
peer 2.2.2.2 connect-interface LoopBack0
#
ip route-static 2.2.2.2 255.255.255.255 12.1.1.2
#
load tr069-configuration
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
#
return
<R1>
<R1>
<R1>dis ip routing-table
Routing Tables: Public
Destinations : 7 Routes : 7
Destination/Mask Proto Pre Cost NextHop Interface
1.1.1.1/32 Direct 0 0 127.0.0.1 InLoop0
2.2.2.2/32 Static 60 0 12.1.1.2 Eth0/0
12.1.1.0/24 Direct 0 0 12.1.1.1 Eth0/0
12.1.1.1/32 Direct 0 0 127.0.0.1 InLoop0
127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0
172.16.1.1/32 Direct 0 0 127.0.0.1 InLoop0
<R1>
R1>dis bgp routing-table
Total Number of Routes: 1
BGP Local router ID is 1.1.1.1
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Network NextHop MED LocPrf PrefVal Path/Ogn
*> 172.16.1.1/32 0.0.0.0 0 0 i
<R1>
<R2>dis curr
<R2>dis current-configuration
#
version 5.20, Release 1719P06, Standard
#
sysname R2
#
configure-user count 5
#
domain default enable system
#
telnet server enable
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple admin
authorization-attribute level 3
service-type telnet
#
interface Aux0
async mode flow
link-protocol ppp
#
interface Ethernet0/0
port link-mode route
ip address 12.1.1.2 255.255.255.0
#
interface Ethernet0/1
port link-mode route
ip address 23.1.1.2 255.255.255.0
#
interface Ethernet1/0
port link-mode route
#
interface NULL0
#
interface LoopBack0
interface LoopBack0
#
bgp 200
undo synchronization
peer 1.1.1.1 as-number 100
peer 3.3.3.3 as-number 200
peer 1.1.1.1 connect-interface LoopBack0
peer 3.3.3.3 next-hop-local
peer 3.3.3.3 connect-interface LoopBack0
#
ip route-static 1.1.1.1 255.255.255.255 12.1.1.1
ip route-static 3.3.3.3 255.255.255.255 23.1.1.3
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
user privilege level 3
set authentication password simple admin
#
return
<R2>
<R2>
<R2>
<R2>dis ip routing-table
Routing Tables: Public
Destinations : 10 Routes : 10
Destination/Mask Proto Pre Cost NextHop Interface
1.1.1.1/32 Static 60 0 12.1.1.1 Eth0/0
2.2.2.2/32 Direct 0 0 127.0.0.1 InLoop0
3.3.3.3/32 Static 60 0 23.1.1.3 Eth0/1
12.1.1.0/24 Direct 0 0 12.1.1.2 Eth0/0
12.1.1.2/32 Direct 0 0 127.0.0.1 InLoop0
23.1.1.0/24 Direct 0 0 23.1.1.2 Eth0/1
23.1.1.2/32 Direct 0 0 127.0.0.1 InLoop0
127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0
172.16.1.1/32 BGP 255 0 1.1.1.1 Eth0/0
<R2>
<R2>dis bgp routing-table
Total Number of Routes: 1
BGP Local router ID is 2.2.2.2
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Network NextHop MED LocPrf PrefVal Path/Ogn
*> 172.16.1.1/32 1.1.1.1 0 0 100i
<R2>
<R3>sys
System View: return to User View with Ctrl+Z.
[R3]
[R3]
[R3]
[R3]dis curr
#
version 5.20, Release 1719P06, Standard
#
sysname R3
#
configure-user count 5
#
domain default enable system
#
telnet server enable
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple admin
authorization-attribute level 3
service-type telnet
#
interface Aux0
async mode flow
link-protocol ppp
#
interface Ethernet0/0
port link-mode route
ip address 34.1.1.3 255.255.255.0
#
interface Ethernet0/1
port link-mode route
ip address 23.1.1.3 255.255.255.0
#
interface NULL0
#
interface LoopBack0
ip address 3.3.3.3 255.255.255.255
#
bgp 200
undo synchronization
peer 4.4.4.4 as-number 200
peer 2.2.2.2 as-number 200
peer 4.4.4.4 reflect-client
peer 4.4.4.4 connect-interface LoopBack0
peer 2.2.2.2 reflect-client
peer 2.2.2.2 connect-interface LoopBack0
#
ip route-static 2.2.2.2 255.255.255.255 23.1.1.2
ip route-static 4.4.4.4 255.255.255.255 34.1.1.4
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
user privilege level 3
set authentication password simple admin
#
return
[R3]
[R3]
<R3>dis ip routing-table
Routing Tables: Public
Destinations : 10 Routes : 10
Destination/Mask Proto Pre Cost NextHop Interface
2.2.2.2/32 Static 60 0 23.1.1.2 Eth0/1
3.3.3.3/32 Direct 0 0 127.0.0.1 InLoop0
4.4.4.4/32 Static 60 0 34.1.1.4 Eth0/0
23.1.1.0/24 Direct 0 0 23.1.1.3 Eth0/1
23.1.1.3/32 Direct 0 0 127.0.0.1 InLoop0
34.1.1.0/24 Direct 0 0 34.1.1.3 Eth0/0
34.1.1.3/32 Direct 0 0 127.0.0.1 InLoop0
127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0
172.16.1.1/32 BGP 255 0 2.2.2.2 Eth0/1
<R3>
<R3>dis bgp routing-table
Total Number of Routes: 1
BGP Local router ID is 3.3.3.3
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Network NextHop MED LocPrf PrefVal Path/Ogn
*>i 172.16.1.1/32 2.2.2.2 0 100 0 100i
<R3>
<R4>dis curr
#
version 5.20, Release 1719P06, Standard
#
sysname R4
#
configure-user count 5
#
domain default enable system
#
telnet server enable
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password simple admin
authorization-attribute level 3
service-type telnet
#
interface Aux0
async mode flow
link-protocol ppp
#
interface Ethernet0/0
port link-mode route
#
interface Ethernet0/1
port link-mode route
ip address 34.1.1.4 255.255.255.0
#
interface NULL0
#
interface LoopBack0
ip address 4.4.4.4 255.255.255.255
#
bgp 200
undo synchronization
peer 3.3.3.3 as-number 200
peer 3.3.3.3 connect-interface LoopBack0
#
ip route-static 3.3.3.3 255.255.255.255 34.1.1.3
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
#
return
<R4>
<R4>
<R4>
<R4>dis ip routing-table
Routing Tables: Public
Destinations : 6 Routes : 6
Destination/Mask Proto Pre Cost NextHop Interface
3.3.3.3/32 Static 60 0 34.1.1.3 Eth0/1
4.4.4.4/32 Direct 0 0 127.0.0.1 InLoop0
34.1.1.0/24 Direct 0 0 34.1.1.4 Eth0/1
34.1.1.4/32 Direct 0 0 127.0.0.1 InLoop0
127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0
<R4>
<R4>dis bgp routing-table
Total Number of Routes: 1
BGP Local router ID is 4.4.4.4
Status codes: * - valid, > - best, d - damped,
h - history, i - internal, s - suppressed, S - Stale
Origin : i - IGP, e - EGP, ? - incomplete
Network NextHop MED LocPrf PrefVal Path/Ogn
i 172.16.1.1/32 2.2.2.2 0 100 0 100i
<R4>dis ip rou