routerA:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial0/1
ip address 192.1.1.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
!
router ospf 10
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.1.1.0 0.0.0.255 area 0
neighbor 192.1.1.2
neighbor 192.1.1.3
routerB:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Serial0/2
ip address 192.1.1.2 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 192.1.1.1 201 broadcast
frame-relay map ip 192.1.1.3 201 broadcast
!
router ospf 10
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 192.1.1.0 0.0.0.255 area 0
routerC:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Serial0/3
ip address 192.1.1.3 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 192.1.1.1 301 broadcast
frame-relay map ip 192.1.1.2 301 broadcast
!
router ospf 10
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 192.1.1.0 0.0.0.255 area 0
看一下邻居的关系,routerA为DR,B,C,为DROTHER
routerA#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/DROTHER 00:01:53 192.1.1.2 Serial0/1
3.3.3.3 0 FULL/DROTHER 00:01:44 192.1.1.3 Serial0/1
看路由表,能够相互学到全部路由
routerA#sh ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 192.1.1.2, 00:15:28, Serial0/1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 192.1.1.3, 00:15:28, Serial0/1
C 192.1.1.0/24 is directly connected, Serial0/1
routerB#sh ip rou
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 192.1.1.1, 00:16:34, Serial0/2
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 192.1.1.3, 00:16:34, Serial0/2
C 192.1.1.0/24 is directly connected, Serial0/2
routerC#sh ip route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 192.1.1.1, 00:16:39, Serial0/3
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 192.1.1.2, 00:16:39, Serial0/3
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
C 192.1.1.0/24 is directly connected, Serial0/3