hdu 2846 Repository - 字典树

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3247    Accepted Submission(s): 1227


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
   
   
   
   
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
   
   
   
   
0 20 11 11 2
 

Source
2009 Multi-University Training Contest 4 - Host by HDU
 
/*
http://acm.hdu.edu.cn/showproblem.php?pid=2846
Repository 字典树变式
*/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <string>
#include <iostream>
using namespace std;

typedef struct node{
	int no;
	int count;
	struct node* next[27];
	node(int _count = 0)
	{
		count = _count;
		no = -1;
		int i;
		for(i = 0 ; i < 27 ; i ++)
		{
			next[i] = NULL;
		}
	}
}Trie;

void insertNode(Trie* trie , char* s,int noo)
{
	Trie* t = trie;
	int i = 0;
	while(s[i] != '\0')
	{
		int tmp = s[i]-'a';
		if(t->next[tmp] == NULL)
		{
			t->next[tmp] = new node(0);
		}
		t = t->next[tmp];
		if(t->no != noo) // noo 做标记 增加数量
		{
			t->count ++;
			t->no = noo;
		}
		i ++;
	}

}

int func(Trie* trie,char s[])
{
	Trie* t = trie;
	Trie* tpre;
	int i = 0;
	while(s[i] != '\0')
	{
		int tmp = s[i]-'a';
		if(t->next[tmp] == NULL)
		{
			return 0;
		}
		tpre = t;
		t = t->next[tmp];
		i ++;
	}
	return t->count;
}

int main()
{
	//freopen("in.txt","r",stdin);
	int n , m ;
	int i , j ;
	scanf("%d",&n);
	char stmp[21];
	Trie* trie = new node(0);
	for(i = 0 ; i < n ; i ++)
	{
		scanf("%s",stmp);
		int len = strlen(stmp);
		/*
			这里对于stmp = "abc" 分为 abc,bc,c这3个字符串插入 
				一次插入后如下图
					   root
					  / |  \
					a   b   c 
				   /    |
				  b     c
				 /
				c
			每次都这样处理, 相应字符的count 会加上去,最后统计count就行了
		*/
		for(j = 0;j < len ;j ++)
		{
			insertNode(trie , stmp+j , i);
		}
	}

	scanf("%d" , &m) ;
	for(i = 0 ; i < m ; i ++)
	{
		scanf("%s",stmp);
		printf("%d\n" , func(trie,stmp) ) ;
	}
	return 0;
}



你可能感兴趣的:(hdu 2846 Repository - 字典树)