hdoj 5533 Dancing Stars on Me【数学】

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 588    Accepted Submission(s): 312


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer  T  indicating the total number of test cases. Each test case begins with an integer  n , denoting the number of stars in the sky. Following  n lines, each contains  2  integers  xi,yi , describe the coordinates of  n  stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
   
   
   
   
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
   
   
   
   
NO YES NO
 

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)


#include<cstring>
#include<cstdio>
#include<cmath>
#define min(a, b)  a>b?b:a
using namespace std;
const int inf = 0x3f3f3f;
double x[150],y[150];
double a[1010][1010];
double getline(int i, int j)
{
	return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		memset(a, 0 , sizeof(a));
		double t = inf;
		int n;
		scanf("%d", &n);
		for(int i = 0; i < n; i++)
		{
			scanf("%lf%lf", &x[i], &y[i]);
		}
		for(int i = 0; i < n; i++)
		{
			for(int j = i+1; j < n; j++)
			{
				a[i][j] = getline(i,j);
				t = min (t, a[i][j]);
			}
		}
		int num = 0;
		for(int i = 0; i < n; i++)
		{
			for(int j = i+1; j < n; j++)
			{
				if(t == a[i][j])
				num++;
			}
		}
		if(num==n)
		puts("YES");
		else
		puts("NO");
	}
	return 0;	
}




你可能感兴趣的:(hdoj 5533 Dancing Stars on Me【数学】)