HDU 1002 大数运算 java 的强大功能

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 123322    Accepted Submission(s): 23706


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

java的强大运算,还记得当年学c++大数加法的时候整整看了一天这道题的代码,要转化成数组进行处理,一年后的今天,学会了大数加法处理这道题。

post code


import java.util.*;
import java.math.*;
import java.io.*;
public class  Main    //注意类名一定要用首字母大写的Main
{
    public static void main( String[] args  )
    {
       Scanner cin=new Scanner(new BufferedInputStream (System.in)  );	
       BigInteger a,b,c;                    //定义了三个大整数
       int ji,num=0;
       ji=cin.nextInt();                    //读入判断条件
       while( ji>=1 )
       {
           ji--;
    	   num++; 
    	   a=cin.nextBigInteger();             //读入大整数
    	   b=cin.nextBigInteger();
    	   c=a.add(b);
    	   System.out.println("Case "+num+":");          //输出结果
    	   System.out.println(a + " + " + b + " = "+c);
           if(ji!=0)System.out.println("");
       }
       
    }
}


你可能感兴趣的:(java,Integer,input,import,each,output)