poj 2823 Sliding Window(简单单调队列)

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 26585   Accepted: 7898
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28, Ikki
题目: http://poj.org/problem?id=2823
题意:维护一个数列里面长度为k的区间的最值
分析:简单地用单调队列来维护即可,如果队首元素与当前元素长度超过k,就出队
PS:今晚出师不利啊,两水题全wa了好几次,这题主要是初始化错了,一开始我只保存了1~k的最值当做初始值,这样是错的= =具体不解释
代码:
#include<cstdio>
#include<iostream>
using namespace std;
const int mm=1111111;
int a[mm],q[mm];
int main()
{
    int i,n,m,l,r;
    while(~scanf("%d%d",&n,&m))
    {
        if(m>n)m=n;
        for(i=1;i<=n;++i)
            scanf("%d",&a[i]);
        l=0,r=-1;
        for(i=1;i<=n;++i)
        {
            while(l<=r&&a[q[r]]>a[i])--r;
            q[++r]=i;
            while(i-q[l]>=m)++l;
            if(i>=m)printf("%d%c",a[q[l]],i<n?' ':'\n');
        }
        l=0,r=-1;
        for(i=1;i<=n;++i)
        {
            while(l<=r&&a[q[r]]<a[i])--r;
            q[++r]=i;
            while(i-q[l]>=m)++l;
            if(i>=m)printf("%d%c",a[q[l]],i<n?' ':'\n');
        }
    }
    return 0;
}


你可能感兴趣的:(c,input,each)