第六届福建省大学生程序设计竞赛-重现赛,Problem J RunningMan

Problem J RunningMan

Accept: 131    Submit: 577
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

 Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).

 Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)

 Sample Input

2
100 100
200 100

 Sample Output

No
Yes

 Hint

In the second example, the RunningMan team can arrange 60, 60, 80 people for the three rounds. No matter how the opposite team arrange their 100 people, they cannot win.

题意:左边的是跑男队,右边的是对手,都要把总人数分成3组,当跑男的小组中的人数大于等于对方时,跑男胜,3局2胜。问有没有一种分法,使得跑男总是赢,有的话yes,没有no。

#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main(){
	int t;
	scanf("%d", &t);
	while(t--)
	{
		int n,m;
		scanf("%d%d", &n,&m);
        int a = n / 3;
        int b = a, c = a;
        int yu = n % 3;
        if(yu == 1)
            a++;
        if(yu == 2)
            a++, b++;
        if(b + c + 2 <= m)
            printf("No\n");
        else
            printf("Yes\n");
    }

	return 0;
}
 




你可能感兴趣的:(第六届福建省大学生程序设计竞赛-重现赛,Problem J RunningMan)