hdu 2141 Can you find it? 二分查找 + 数组合并

Can you find it?

                                                                         Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
   
   
   
   
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
   
   
   
   
Case 1: NO YES NO
一开始我就按照题目所给的那样,用了3个for循环比较L[i]+N[j]+M[k]是否与x相等,结果WA了几次,也找不出错误原因,后来才知道要把L和N数组合并,并且用到二分查找,结果按照别人的思想写了一下,还真过了,看来自己做的题还是太少了,还不能把学习的东西灵活运用。
参考代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
#define K 505
int LN[K*K]; int BinarySearch(int LN[],int h,int t)/*二分查找*/ { int left,right,mid;
    left=0;
    right=h-1;
    mid=(left+right)/2; while(left<=right) {
        mid=(left+right)/2; if(LN[mid]==t) return 1; else if(LN[mid]>t)
          right=mid-1; else if(LN[mid]<t)
          left=mid+1; } return 0; } int main() { int i,j,count=1,q;
    __int32 L[K],N[K],M[K],S,n,m,l; while(scanf("%d%d%d",&l,&n,&m)!=EOF) { int h=0; for(i=0;i<l;i++)
         scanf("%d",&L[i]); for(i=0;i<n;i++)
          scanf("%d",&N[i]); for(i=0;i<m;i++)
          scanf("%d",&M[i]); for(i=0;i<l;i++) for(j=0;j<n;j++)
           LN[h++]=L[i]+N[j];/*合并L和N*/
        sort(LN,LN+h); /*对LN数组排序*/
        scanf("%d",&S);
        printf("Case %d:\n",count++); for(i=0;i<S;i++) {
            scanf("%d",&q);/*q即为题目中的x*/ int p=0; /*p为标记,0为找不到,1为能找到*/ for(j=0;j<m;j++) { int a=q-M[j]; /*因为L[i]+N[j]+M[k]==q,所以q-M[k]=LN[h]*/ if(BinarySearch(LN,h,a)) /*在LN数组中查找到a*/ {
                    printf("YES\n");
                    p=1; break; } } if(!p) /*找不到a*/
              printf("NO\n"); } } return 0; }

你可能感兴趣的:(hdu 2141 Can you find it? 二分查找 + 数组合并)