UVa 11988 - Broken Keyboard (a.k.a. Beiju Text)【链表初接触】

Broken Keyboard (a.k.a. Beiju Text)

You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problemwith the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed(internally).You’re not aware of this issue, since you’re focusing on the text and did not even turn on themonitor! After you finished typing, you can see a text on the screen (if you turn on the monitor).In Chinese, we can call it Beiju. Your task is to find the Beiju text.

Input

There are several test cases. Each test case is a single line containing at least one and at most 100,000letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressedinternally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file(EOF).

Output

For each case, print the Beiju text on the screen.


Sample Input

This_is_a_[Beiju]_text

[[]][][]Happy_Birthday_to_Tsinghua_University

Sample Output

BeijuThis_is_a__text

Happy_Birthday_to_Tsinghua_University

链表的初次接触,一开始的确没明白。(链表并不一定要用指针)

<span style="font-size:18px;color:#330033;">#include<cstdio>
#include<cstring>
const int maxn=100005;
int last,cur,next[maxn];
char s[maxn];
int main(){
    while(scanf("%s",s+1)==1){
        int n=strlen(s+1);
        last=cur=0;
        next[0]=0;
        for(int i=1;i<=n;i++){
            char ch=s[i];
            if(ch=='[')cur=0;
            else if(ch==']')cur=last;
            else{
                next[i]=next[cur];
                next[cur]=i;
                if(cur==last)last=i;
                cur=i;
            }
        }
        /*for(int i=0;i<=n;i++)
            printf("%d: %d\n",i,next[i]);*/
        for(int i=next[0];i!=0;i=next[i])
            printf("%c",s[i]);
        printf("\n");
    }
    return 0;
}
</span>


你可能感兴趣的:(链表,printf,strlen,uva,CString)