选择几何图形

/* 
*Copyright (c) 2013 ,烟台大学计算机学院 
*All rights reserved. 
*作者:张凤宁
*完成日期:2013年11月7日
*版本号:v1.0 
*问题描述:选择一个几何图形 
*样例输入: 
*样例输出: 
*问题分析:用简单的方法,学会活学活用 
*/ 

#include <iostream>

using namespace std;

int main()
{
    int num;
    double height,width,h,a,b,s,r,area;
    cout<<"请选择几何图形:"<<endl;
    cout<<"1:矩形   2:三角形  3:圆"<<endl;
    cin>>num;
    if(num==1)
    {
        cout<<"请输入矩形的高和宽:";
        cin>>height>>width;
        s=height*width;
        cout<<"该矩形的面积是:"<<s<<endl;
        cout<<"欢迎继续使用!"<<endl;

    }
    else if(num==2)
    {
        cout<<"请输入三角形的一条边及该边对应的高:";
        cin>>b>>h;
        a=0.5*b*h;
        cout<<"该三角形的面积是:"<<a<<endl;
        cout<<"欢迎继续使用!"<<endl;
    }
    else if(num==3)
    {
        cout<<"请输入圆的半径:";
        cin>>r;
        area=3.14*r*r;
        cout<<"该圆的面积是:"<<area<<endl;
        cout<<"欢迎继续使用!"<<endl;
    }
    else
    {
        cout<<"您的选择有误,请重新选择!"<<endl;
    }
    return 0;
}

运行结果:

你可能感兴趣的:(选择几何图形)