hdu 1241 Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7359 Accepted Submission(s): 4301


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
   
   
   
   
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output
   
   
   
   
0 1 2 2

Source
Mid-Central USA 1997

Recommend
Eddy
简单深搜。联通快问题。
#include <stdio.h>
#include<string.h>

int dx[8]={-1,-1,0,1,1,1,0,-1};//标记方向
int dy[8]={0,1,1,1,0,-1,-1,-1};
int m,n;
char maze[150][150];//记录地图

void dfs(int px,int py)//px,py当前位置
{
    int i,nx,ny;//nx,ny下个位置

    for(i=0;i<8;i++)
    {
        nx=px+dx[i];
        ny=py+dy[i];
        if(nx>m||nx<1||ny>n||ny<1||maze[nx][ny]=='*')
            continue;
        maze[nx][ny]='*';
        dfs(nx,ny);
    }
}
int main()
{
    int cnt,i,j;

    while(scanf("%d%d",&m,&n),m||n)
    {
        getchar();
        cnt=0;
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%c",&maze[i][j]);
            }
            getchar();
        }
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(maze[i][j]=='@')
                {
                    maze[i][j]='*';
                    dfs(i,j);
                    cnt++;//如果该位置还为被包含说明是另一个块
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


你可能感兴趣的:(c,算法,ACM)