ACM-并查集之How Many Tables——hdu1213

How Many Tables

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1213

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2

4


基础的并查集,数集合个数问题,和畅通工程一样的解题方案(我拿它代码改了下输入格式就A了。。。)

http://blog.csdn.net/lttree/article/details/23820679


#include <stdio.h>
const int MAX=1000;
int father[MAX];

//初始化函数
void Init(int n)
{
    int i;
    for(i=1;i<=n;i++)
        father[i]=i;
}
//查找函数
int Find(int x)
{
    while(father[x]!=x)
        x=father[x];

    return x;
}
//合并函数
void combine(int a,int b)
{
    int temp_a,temp_b;
    temp_a=Find(a);
    temp_b=Find(b);

    if(temp_a!=temp_b)
        father[temp_a]=temp_b;
}
//确定连通分量个数
int find_ans(int n)
{
    int i,sum=0;
    for(i=1;i<=n;++i)
        if(father[i]==i)
            ++sum;
    return sum;
}

int main()
{
    int i,n,m,a,b,test;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d%d",&n,&m);
        Init(n);
        for(i=0;i<m;++i)
        {
            scanf("%d%d",&a,&b);
            combine(a,b);
        }
        printf("%d\n",find_ans(n));
    }
    return 0;
}


你可能感兴趣的:(ACM,并查集,tables,how,many,hdu1213)