HDU 2070 Fibbonacci Number 题解

HDU 2070 Fibbonacci Number 题解

Fibbonacci Number

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10868 Accepted Submission(s): 5549


Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.


Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.


Output
Print out the answer in a single line for each test case.


Sample Input
3
4
5
-1


Sample Output
2
3
5

水题,先预处理就可以到前50个然后按输入读数组就可以了

HDU2070.cpp
#include <iostream>
#include <cstdio>
using namespace std;
#define MAXN 50+10
__int64 F[MAXN];
int main()
{
    F[0] = 0; F[1] = 1;
    for(int i = 2;i <= 50;i++)
    {
        F[i] = F[i-1] + F[i-2];
    }
    int n;
    while(scanf("%d",&n),n!=-1)
    {
        printf("%I64d\n",F[n]);
    }
    return 0;
}

你可能感兴趣的:(HDU 2070 Fibbonacci Number 题解)