POJ 3468 (线段树,区间更新,查询区间)

A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 46058   Accepted: 13513
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi


不多说什么了,注意一下数据范围就行


//A Simple Problem with Integers//
//题目链接:http://poj.org/problem?id=3468

#include<iostream>
#include<cstdio>
#include<cstring>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define manx 111111
#define LL long long int
LL sum[manx<<2];
LL tot[manx<<2];
void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
	if(tot[rt])
	{
	tot[rt<<1]+=tot[rt];
	tot[rt<<1|1]+=tot[rt];
	sum[rt<<1]+=(m-(m>>1))*tot[rt];
	sum[rt<<1|1]+=(m>>1)*tot[rt];
	tot[rt]=0;
	}
}
void build(int l,int r,int rt)
{
	tot[rt]=0;
	if(l==r)
	{
		scanf("%lld",&sum[rt]);
		return ;
	}
	int m=(l+r)>>1;
	build(lson);
	build(rson);
	pushup(rt);
}
void update(int L,int R,int add,int l,int r,int rt)
{
	if(L<=l&&r<=R)
	{
		sum[rt]+=add*(r-l+1);
		tot[rt]+=add;
		return ;
	}
	pushdown(rt,r-l+1);
	int m;
	m=(l+r)>>1;
	if(L<=m) update(L,R,add,lson);
	if(R>m) update(L,R,add,rson);
	pushup(rt);
}
LL query(int L,int R,int l,int r,int rt)
{
	if(L<=l&&r<=R)
		return sum[rt];
	pushdown(rt,r-l+1);
	LL ret=0;
	int m;
	m=(l+r)>>1;
	if(L<=m) ret+=query(L,R,lson);
	if(R>m)  ret+=query(L,R,rson);
	return  ret;
}
int main()
{
	int n,q;
	char op[2];
	int i,j;
	int a,b,c;
	LL result;
	int start,end;
	while(scanf("%d%d",&n,&q)!=EOF)
	{
		build(1,n,1);
		for(i=1;i<=q;i++)
		{
			scanf("%s",op);
			if(op[0]=='C')
			{
				scanf("%d%d%d",&a,&b,&c);
				update(a,b,c,1,n,1);
			}
			else
				if(op[0]=='Q')
				{
					scanf("%d%d",&start,&end);
					result=query(start,end,1,n,1);
					printf("%lld\n",result);
				}
		}
	}
	return 0;
}


你可能感兴趣的:(POJ 3468 (线段树,区间更新,查询区间))