Card Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1810 Accepted Submission(s): 836
Special Judge
Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.
As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.
Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.
You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
Sample Input
Sample Output
Source
2012 Multi-University Training Contest 4
Recommend
zhoujiaqi2010
题意:
有n种卡片,吃零食的时候会吃到一些卡片,告诉你在一袋零食中吃到每种卡片
的概率,求搜集齐每种卡片所需要买零食的袋数的期望。
思路:
n比较小,很自然的想到状态压缩DP
再分析一下转移过程的递推式就行了
设S状态中为1的数位表示对应数位卡片已经拿到。0代表没拿到,那么每次可能会
拿到其中没拿的某一张卡片,也可能拿到原来已经拿到的卡片,还可能一张卡片也拿不到
后两种情况的状态不变。
dp[(1<<n)-1]=0;(表示每一种卡片都取完了,期望当然是0喽)
dp[S]=sum*dp[S]+p[x1]dp[S^(1<<x1)]+p[x2]dp[S^(1<<x2)].....+1;
sum是后两种情况的概率之和
移项,化简即可得到dp[S]的表达式
最后输出dp[0]表示每一种卡片都没取时候的期望。
开始做有点难以理解,做完后对期望的认识又深入了一点。
详细见代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<queue>
using namespace std;
double dp[1<<22],p[22],sum,no,same;
int main()
{
int i,j,n;
while(~scanf("%d",&n))
{
no=0;
for(i=0; i<n; i++)
{
scanf("%lf",p+i);
no+=p[i];
}
no=1-no;//一张也没中的概率
dp[(1<<n)-1]=0;//已经全中了期望肯定为0
for(i=(1<<n)-2; i>=0; i--)
{
sum=1;
same=0;
for(j=0; j<n; j++)
{
if(i&(1<<j))//状态一样
same+=p[j];
else
sum+=dp[i|(1<<j)]*p[j];
}
dp[i]=sum/(1-same-no);
}
printf("%.5lf\n",dp[0]);
}
return 0;
}