HDU 1063Exponentiation(Java的大数处理)

Exponentiation

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5665    Accepted Submission(s): 1557


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 
 

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 

Sample Input
   
   
   
   
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
 

Sample Output
   
   
   
   
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
 

                    题目大意:给你一个实数a,一个整数n,让你求a的n次方,如果小数后面多余有0去掉,如果整数位为0直接输出小数点,见第二个输出样例。

           解题思路:需要用到BigDecimal的一个类,来去除后面的小数点,直接调用strip..toPlainString函数,还有就是输出String的某一位的时候,是用charAt多少来输出的。

           题目地址:Exponentiation

AC代码:
import java.util.*;

import java.math.*;

public class Main {     //感谢蜗牛!
    public static void main(String args[])
    {
    	 Scanner cin = new Scanner(System.in);
    	 String p;
    	 int n;
    	 BigDecimal res;
    	 BigDecimal one=BigDecimal.ONE;
    	 while(cin.hasNext())
    	 {
    		 res=cin.nextBigDecimal();
    		 n=cin.nextInt();
    		 res=res.pow(n);
    		 if(res.compareTo(one)>=0)  //大于1只需要去掉后面的0即可
    			 System.out.println(res.stripTrailingZeros().toPlainString());
    		 else
    		 {
    			 String ans=res.stripTrailingZeros().toPlainString();
    			 for(int i=1;i<ans.length();i++)
    				 System.out.print(ans.charAt(i));  //不要第一位
    			 System.out.println();
    		 }
    	 }
    }
}


你可能感兴趣的:(java,数学,HDU)