Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2719 Accepted Submission(s): 1794
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
本题用深搜来做,简单!!!!
#include<iostream>
using namespace std;
char g[22][22];
int vis[22][22],count,xx,yy,w,h,sx,sy;
int dir[][2]={{1,0},{-1,0},{0,1},{0,-1}};
void dfs(int x,int y)
{
int i;
if(g[y][x]=='#')return;
else
{
vis[y][x]=1;
for( i=0; i<4; i++ )
{
yy=y+dir[i][0];
xx=x+dir[i][1];
if( x<w && xx>=0 && y<h && yy>=0 && vis[yy][xx]==0)
{
dfs(xx,yy);
}
}
}
}
int main()
{
void dfs(int x,int y);
int i,j;
while( cin>>w>>h,w,h)
{
count=0;
for( i=0; i<h; i++)
{
for( j=0; j<w; j++)
{
cin>>g[i][j];
vis[i][j]=0;
}
}
for( i=0; i<h; i++)
{
for( j=0; j<w; j++)
{
if( g[i][j]=='@')
{
sx=j;
sy=i;
}
}
}
dfs(sx,sy);
//cout<<count<<endl;
for( i=0; i<h; i++)
{
for( j=0; j<w; j++)
{
if( vis[i][j]==1)
{
count++;
}
}
}
cout<<count<<endl;
}
return 0;
}