uva 10391 - Compound Words

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn
第一次用的Bkdrhash还不是很熟练,照着敲了一遍,还有很多字符串的哈希函数不熟悉
保存每个读入的字符串,计算出哈希值排序,之后对每个字符串穷举不同的分法,计算哈希值后二分查找是否存在。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[120000],t=-1,sum=0;
char s[120000][30],ch1[30],ch2[30];
int comp(int a,int b)
{return a<b;};
int Bkdrhash(char *str)
{int seed=31,hash=0;
 while (*str)
 hash=hash*seed+*str++;
 return hash&0x7FFFFFFF;
};
int Find(int key,int l,int r)
{int mid=(l+r)/2;
 if (l>r) return 0;
 if (a[mid]==key) return 1;
 else if (a[mid]>key) Find(key,l,mid-1);
                else  Find(key,mid+1,r);
};
int main()
{int i,j,k,l;
 freopen("a.in","r",stdin);
 freopen("a.out","w",stdout);
 while (gets(s[++t]))
 a[t]=Bkdrhash(s[t]);
 sort(a,a+t,comp);
 for (i=0;i<t;i++)
 {l=strlen(s[i]);
  for (j=0;j<l-1;j++)
  {
   for (k=0;k<=j;k++)
   ch1[k]=s[i][k];
   ch1[j+1]='\0';
   for (k=j+1;k<l;k++)
   ch2[k-j-1]=s[i][k];
   ch2[l-j-1]='\0';
   if (Find(Bkdrhash(ch1),0,t-1)+Find(Bkdrhash(ch2),0,t-1)==2) {puts(s[i]);break;} //对于形如a,aaa,aaaa,字符串拆分存在重复,a+aaa,aaa+a,直接break掉,
  }
 }
 fclose(stdin);
 fclose(stdout);
 return 0;
}

你可能感兴趣的:(uva 10391 - Compound Words)