poj 3624 Charm Bracelet (01背包)

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23771   Accepted: 10708

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
我的第一道01背包题。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int w[3500],d[3500];
int dp[13000];

int max(int a,int b)
{
    return a>b?a:b;
}

int main()
{
    int i,j;
    int n,m;
    while(cin>>n>>m)
    {
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&w[i],&d[i]);
        }
        for(i=1;i<=n;i++)
        {
            for(j=m;j>=w[i];j--)
            {
                dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
            }
        }
        cout<<dp[m]<<endl;
    }
    return 0;
}


你可能感兴趣的:(c,算法,printf,ACM,iostream)