Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10410 Accepted Submission(s): 6505
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
Source
Asia 2004, Ehime (Japan), Japan Domestic
Recommend
Eddy | We have carefully selected several similar problems for you: 1241 1016 1010 1372 1242
#include<stdio.h>
#include<stdlib.h>
int zb[4][2]={-1,0,1,0,0,-1,0,1};
char s[25][25];
int w,h,step;//这三个值一定要用全局变量。
int pd(int x, int y)
{
int xx,yy;
if(x>=w||x<0||y>=h||y<0)return 0;
for(int i=0;i<4;i++)//检查该点上下左右的点是否符合题目要求。
{
xx=x+zb[i][0];
yy=y+zb[i][1];
if(xx>=w||xx<0||yy>=h||yy<0||s[xx][yy]=='#')continue;//检查坐标为xx,yy的点。
step++;
s[xx][yy]='#';//如果该点已经检查过,就把它变成'#',防止再次被检查。
pd(xx,yy);
}
}
int main()
{
int pd(int x,int y);
while(scanf("%d%d",&w,&h),w!=0&&h!=0)
{
getchar();
int x1,y1;
for(int i=0;i<h;i++)
{
for(int j=0;j<w;j++)
{
scanf("%c",&s[j][i]);
if(s[j][i]=='@')
{
x1=j;
y1=i;
}
}
getchar();//记得吸收换行符。
}
s[x1][y1]='#';
step=1;
pd(x1,y1);
printf("%d\n",step);
}
return 0;
}