hdu 1525 Euclid's Game 博弈~~需要分析一下

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2223    Accepted Submission(s): 1001


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

 

Sample Input
   
   
   
   
34 12 15 24 0 0
 

Sample Output
   
   
   
   
Stan wins Ollie wins
 
看一个大神博客~
http://www.cnblogs.com/kuangbin/p/3204627.html

代码:
#include <stdio.h>

void swap(int &a , int &b)
{
	int temp = a ;
	a = b ;
	b = temp ;
}

int main()
{
	int n ;
	int a,b;
	while(~scanf("%d%d",&a,&b) && (a+b) )
	{
		if(a<b)
		{
			swap(a,b) ;
		}
		if(a/b>=2)
		{
			puts("Stan wins") ;
		}
		else
		{
			int win = 0 ;
			while(b)
			{
				if(a%b==0 || a/b >= 2)
					break ;
				a = a-b ;
				swap(a,b) ;
				win ^= 1 ;
			}
			if(win == 0)
				puts("Stan wins") ;
			else
				puts("Ollie wins") ;
		}
	}
	return 0 ;
}

与君共勉

你可能感兴趣的:(ACM,game,博弈,Euclids,hdu1525)