HDOJ 1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 87137    Accepted Submission(s): 32909


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
   
   
   
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
   
   
   
   
red pink
 
 
看讨论区里说的这是map的应用题,但是不会map,就用了水题的方法做了,具体代码如下:
 
#include<stdio.h>
#include<string.h>
char str[1100][20];
int count[1000];

int main()
{
	int n,i,j,max,t;
	while(scanf("%d",&n)&&n!=0)
	{
		max=0;
		for(i=0;i<n;i++)
		   scanf("%s",str[i]);
		for(i=0;i<n;i++)
		{
			count[i]=1;
			for(j=i+1;j<n;j++)
			{
				if(strcmp(str[i],str[j])==0)
				  count[i]++;
			}
			if(count[i]>max)
		    {
			    max=count[i];
			    t=i;
		    }
		}
	    printf("%s\n",str[t]);
	}
	return 0;
}


你可能感兴趣的:(HDOJ 1004 Let the Balloon Rise)