hdu 4586 Play the Dice(水期望DP)

Play the Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 308    Accepted Submission(s): 136
Special Judge


Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
 

Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
 

Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
 

Sample Input
   
   
   
   
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
 

Sample Output
   
   
   
   
3.50 0.00
 

Source
2013 ACM-ICPC南京赛区全国邀请赛——题目重现
 

Recommend
zhuyuanchen520
 

题意:

给定一个n面均匀的筛子,每个面都有一个值,另外有m面如果投到会有再投一次的机会(可以投无限此),问你他的概率是多少。

思路:

开始想复杂了。居然连高斯消元都用上了。其实很简单的。

只考虑第一次,获得的金币的平均值为sum/n.sum为所有色子的面的金币值相加。
对于运气好,摇中了可以再来一次,该轮就能获得m/n*(sum/n)
运气好,又再来一次,该轮能获得(m/n)^2*(sum/n)
无穷无尽的摇下去,一共能获得sum/n*(1+p + p^2+`````+p^k + ````),其中per= m/n
将式子化简,就能得到E = sum/(n-m)。所以当sum = 0时为0,n=m时为inf。其余就为sum/(n-m)。

详细见代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;
int a;

int main()
{
    int i,n,m;
    double ans;

    while(~scanf("%d",&n))
    {
        ans=0;
        for(i=0; i<n; i++)
        {
            scanf("%d",&a);
            ans+=a;
        }
        scanf("%d",&m);
        for(i=0; i<m; i++)
            scanf("%d",&a);
        if(ans==0)//必须这么写
            printf("0.00\n");
        else if(n==m)//n=m且ans不为0才为inf
            printf("inf\n");
        else
            printf("%.2lf\n",ans/(n-m));
    }
    return 0;
}


你可能感兴趣的:(c,算法,ACM)