HDOJ Intersection 5120【环相交面积】

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 949    Accepted Submission(s): 360


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.

HDOJ Intersection 5120【环相交面积】_第1张图片
A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.

HDOJ Intersection 5120【环相交面积】_第2张图片
Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
   
   
   
   
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
   
   
   
   
Case #1: 15.707963 Case #2: 2.250778
 

Source
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5338  5337  5336  5335  5334 
 
几何题,注意精度  PI 用 acos(-1.0)表示 否则会wa。
HDOJ Intersection 5120【环相交面积】_第3张图片

求黑色面积 可以用大圆相交面积-两个大小圆相交面积+小圆相交面积

#include <stdio.h>
#include <math.h>
#include <vector>
#include <queue>
#include <string>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define PI acos(-1.0)
using namespace std;

struct point{
    double x,y;
};
const double eps=1e-20;

double dist(point C1,point C2)
{
    return sqrt((C1.x-C2.x)*(C1.x-C2.x)+(C1.y-C2.y)*(C1.y-C2.y));
}
double aear(point c1,double r1,point c2,double r2)
{
    double d=dist(c1,c2);
    if(r1+r2-d<eps) return 0;
    if(d<fabs(r1-r2)+eps)
    {
        double r=min(r1,r2);
        return PI*r*r;
    }
    double x=(d*d+r1*r1-r2*r2)/(2*d);
    double t1=acos(x/r1);
    double t2=acos((d-x)/r2);
    return r1*r1*t1+r2*r2*t2-d*r1*sin(t1);
}

int main()
{
    int t;
    scanf("%d",&t);
    int xp=1;
    while(t--)
    {
        double r,R;
        scanf("%lf%lf",&r,&R);
        point C1,C2;
        scanf("%lf%lf%lf%lf",&C1.x,&C1.y,&C2.x,&C2.y);
        double ringr_R=aear(C1,r,C2,R);
        double ringr_r=aear(C1,r,C2,r);
        double ringR_r=aear(C1,R,C2,r);
        double ringR_R=aear(C1,R,C2,R);
        printf("Case #%d: %.6lf\n",xp++,ringR_R-ringR_r-ringr_R+ringr_r);
    }
    return 0;
}


你可能感兴趣的:(HDOJ Intersection 5120【环相交面积】)