POJ 3624 Charm Bracelet

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14051   Accepted: 6423

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December 



思路:完全裸露的01背包

#include<stdio.h>
#define max(a,b) (a)>(b)?(a):(b)
int dp[12888];
int w[3408],d[3408];
int main()
{
   int n,m,i,j;
   while(scanf("%d%d",&n,&m)!=EOF)
   {
      for(i=0;i<n;i++)
	    scanf("%d%d",&w[i],&d[i]);
	  for(i=0;i<=m;i++) dp[i]=0;
	  for(i=0;i<n;i++)
	    for(j=m;j>=w[i];j--)
		  dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
      printf("%d\n",dp[m]);
   }
   return 0;
}


你可能感兴趣的:(POJ 3624 Charm Bracelet)