poj 2406 Power Strings 【KMP】

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 40358   Accepted: 16786

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
const int N = 1000000+10;
char s[N];
int p[N], ls;
void getp()
{
	int i = 0, j = -1;
	p[i] = j;
	while(i < ls)
	{
		if(j==-1||s[i]==s[j])
		{
			i++, j++;
			p[i] = j;
		}
		else  j = p[j];
	}
	int ans;
	if(ls % (ls-p[ls]) == 0)  ans = ls/(ls-p[ls]);
	else  ans = 1;
	Pi(ans);
}

int main()
{
	while(scanf("%s", s)!=EOF)
	{
		if(strcmp(s, ".")==0)   break;
		ls = strlen(s);
		getp();
	}
	return 0;
} 


你可能感兴趣的:(poj 2406 Power Strings 【KMP】)