Humble Numbers
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
这道题就是求所有 由2,3,5,7 相乘而组成的数字,从小到大排列, 方法就是:后面的数肯定是由前面的数乘以2,3,5,7中的最小值, 假设刚开始,第一个数为 1,第二个数肯定是 2,3,5,7分别乘以1的数中的最小值, 最小的当然是2,第二个数就是2*1=2了, 但自此以后2不能再乘以1 和 3,5,7乘以1比较, 而是要向后推一个去相乘,即用2乘以第二个数来和3,5,7乘以第一个数 比较。 从而算出所有5842个数据。 最后,还是那句话,注意格式!
这道题还有一个注意事项,就是在min函数比较的时候,判断第二组判断,4个if 不要写成if...else if...else if...else...的情况, 当计算到第六组数据 6 6 10 7 3 2 2 1 上面是传到Min函数的a,b,c,d四个数据,下面是i,j,k,l 这时候如果用else if 只会让第一个i++,这样第七组数据就会是 8 6 10 7 4 2 2 1 将会是6最小,第六组和第七组同时为6,显然不是我们所求的, 所以四个if 可以避免这种情况,让值相同的相应i,j,k,l都++,避免出现连续多个相同的数
#include <stdio.h>
using namespace std;
int f[5843],n;
int i,j,k,l;
int min(int a,int b,int c,int d)
{
// 找出最小的并返回
int min=a;
if(b<min) min=b;
if(c<min) min=c;
if(d<min) min=d;
if(a==min) i++;
if(b==min) j++;
if(c==min) k++;
if(d==min) l++;
return min;
}
int main()
{
i=j=k=l=1;
f[1]=1;
// 算出所有的5842个数据
for(int t=2;t<=5842;t++)
{
f[t]=min(2*f[i],3*f[j],5*f[k],7*f[l]);
}
// 注意输出格式
while(scanf("%d",&n)&&n!=0)
{
if(n%10==1&&n%100!=11)
printf("The %dst humble number is %d.\n",n,f[n]);
else if(n%10==2&&n%100!=12)
printf("The %dnd humble number is %d.\n",n,f[n]);
else if(n%10==3&&n%100!=13)
printf("The %drd humble number is %d.\n",n,f[n]);
else
printf("The %dth humble number is %d.\n",n,f[n]);
}
return 0;
}