OJ刷题之《发工资咯》

<span style="color: blue; font-family: 'Helvetica Neue', Helvetica, Arial, sans-serif; font-size: 24px; line-height: 36px; background-color: rgb(255, 255, 255);">Description</span>

作为SDIBT的老师,最盼望的日子就是每月的10号了,因为这一天是发工资的日子,养家糊口就靠它了,呵呵 但是对于学校财务处的工作人员来说,这一天则是很忙碌的一天,财务处的小胡老师最近就在考虑一个问题:如果每个老师的工资额都知道,最少需要准备多少张人民币,才能在给每位老师发工资的时候都不用老师找零呢? 这里假设老师的工资都是正整数,单位元,人民币一共有100元、50元、10元、5元、2元和1元六种。

Input

输入数据包含多个测试实例,每个测试实例的第一行是一个整数n(n<100),表示老师的人数,然后是n个老师的工资。 n=0表示输入的结束,不做处理。

Output

对于每个测试实例输出一个整数x,表示至少需要准备的人民币张数。每个输出占一行。

Sample Input

3
1 2 3
0

Sample Output

4

HINT


代码如下:

#include <iostream>
using namespace std;
int main()
{
    int n,i,num=0;
    int a[100];
    while (cin>>n&&n!=0)
    {
        for (i=0; i<n; i++)
            cin>>a[i];
        for (i=0; i<n; i++)
        {
            num+=a[i]/100;
            if (a[i]%100==0)
                continue;
            else
                a[i]%=100;
            num+=a[i]/50;
            if (a[i]%50==0)
                continue;
            else
                a[i]%=50;
            num+=a[i]/10;
            if (a[i]%10==0)
                continue;
            else
                a[i]%=10;
            num+=a[i]/5;
            if (a[i]%5==0)
                continue;
            else
                a[i]%=5;
            num+=a[i]/2;
            if (a[i]%2==0)
                continue;
            else
                a[i]%=2;
            num+=a[i];
        }
        cout<<num<<endl;
        num=0;
    }
    return 0;
}

运行结果:

OJ刷题之《发工资咯》_第1张图片

贪心算法很好用。


你可能感兴趣的:(编程,C++,namespace,String,iostream)