HDU_1671_Phone List(字典树)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11885    Accepted Submission(s): 4040



Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
   
   
   
   
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
   
   
   
   
NO YES


题意:判断给定号码中是否存在某个号码是其他某号码的前缀,存在输出“NO”,否则输出“YES”。

解析:利用字典树处理。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1671

代码清单:

#include<map>
#include<cmath>
#include<stack>
#include<queue>
#include<ctime>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;

const int MAX = 11;
struct trie{
    int point;
    trie *next[MAX];
};

trie *root;
int t,n,flag;
char s[MAX];

void Trie(char *s){
    trie *p=root, *q;
    int len=strlen(s), pos;
    for(int i=0;i<len;i++){
        pos=s[i]-'0';
        if(p->next[pos]==NULL){
            q=new trie();
            q->point=0;
            for(int j=0;j<MAX;j++)
                q->next[j]=NULL;
            p->next[pos]=q;
            p=p->next[pos];
        }
        else{
            if(p->next[pos]->point){ //前面某个号码是当前的前缀
                flag=1;
                return ;
            }
            p=p->next[pos];
        }
    }
    p->point=1;
    for(int i=0;i<MAX;i++){
        if(p->next[i]){   //当前号码是前面某个号码的前缀
            flag=1;
            return ;
        }
    }
}

void delTrie(trie *Root){  //释放内存空间
    for(int i=0;i<MAX;i++){
        if(Root->next[i]!=NULL)
            delTrie(Root->next[i]);
    }
    free(Root);
}

int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        root=new trie();
        for(int i=0;i<MAX;i++)
            root->next[i]=NULL;
        flag=0;
        for(int i=0;i<n;i++){
            scanf("%s",s);
            Trie(s);
        }
        if(flag) printf("NO\n");
        else     printf("YES\n");
        delTrie(root);
    }
    return 0;
}



你可能感兴趣的:(Algorithm,ACM,HDU,trie)