hdu3311之状态压缩dp

Hie with the Pie
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 3479   Accepted: 1811

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=(1<<11)+10;
int n;
int dp[MAX][12],dist[12][12];

void floyd(){
	for(int k=0;k<=n;++k){
		for(int i=0;i<=n;++i){
			for(int j=0;j<=n;++j){
				if(dist[i][j]>dist[i][k]+dist[k][j]){
					dist[i][j]=dist[i][k]+dist[k][j];
				}
			}
		}
	}
}

void DP(){
	int bit=1<<(n+1);
	for(int i=0;i<bit;++i){
		for(int j=0;j<=n;++j)dp[i][j]=INF;
	}
	dp[1][0]=0;
	for(int i=1;i<bit;++i){
		/*for(int k=0;k<=n;++k){//这个双循环是更新dp[i][j],比如1->2->3->2可能比1->3->2更短,虽然重复多经过了一个地方 
			for(int j=0;j<=n;++j){
				//if(!(i&(1<<j)))continue;
				dp[i][j]=min(dp[i][j],dp[i][k]+dist[k][j]);//dp[i][j]表示状态为i且最后到达的城市是j时走的最短距离 
			}
		}*/ 
		for(int k=0;k<=n;++k){//这个双循环是更新从已走的城市到下一个未走的城市的距离 
			for(int j=0;j<=n;++j){
				//if(i&(1<<j))continue;//去掉这个条件就可以把两个双循环合并 
				dp[i|(1<<j)][j]=min(dp[i|(1<<j)][j],dp[i][k]+dist[k][j]);//从城市k->j更新状态dp[i|(1<<j)][j] 
			}
		}
	}
	printf("%d\n",dp[bit-1][0]);
} 

int main(){
	while(~scanf("%d",&n),n){
		for(int i=0;i<=n;++i){
			for(int j=0;j<=n;++j){
				scanf("%d",&dist[i][j]);
			}
		}
		floyd();
		DP();
	}
	return 0;
}



你可能感兴趣的:(hdu3311之状态压缩dp)