九度题目1433:FatMouse(贪心算法)

题目描述:

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

输入:

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

输出:

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入:
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
样例输出:
13.333
31.500
我的思路分析:
这是典型的贪心思想 简单题。
每次都买剩余物品中性价比(即重量价格比)最高的物品,直到该物品被买完或者钱耗尽。若该物品已经被买完,则我们继续在剩余的物品中寻找性价比最高的物品,重复该过程;若金钱耗尽,则交易结束。
 
  
代码:
#include <iostream>
#include <algorithm>
using namespace std;


struct G{
double j;
double f;
double s;	//物品性价比
bool operator <(const G &A) const{
	return s>A.s;
}//重载小于运算符,确保可用sort函数将数组按照性价比降序排列
}buf[1000];	
int main()
{
	double m;
	int n;
	while(cin>>m>>n != 0) { 
		if(m== -1 && n== -1) break; //当n == -1且m == -1时跳出循环,程序运行结束
		for(int i= 0;i< n;i++) { 
			cin>>buf[i].j>>buf[i].f; 
			buf[i].s= buf[i].j/ buf[i].f; //计算性价比
				sort(buf,buf+ n); 
		int idx= 0; //当前货物下标
		double ans= 0;//累加所能得到的总重量
		while(m> 0 && idx< n) { //循环条件为,既有物品剩余(idx < n)还有钱剩余(m > 0)时继续循环
			if(m> buf[idx].f) { 
				ans+= buf[idx].j; 
				m-= buf[idx].f; 
			}	 //若能买下全部该物品
			else{ 
				ans+= buf[idx].j* m/ buf[idx].f; 
				m= 0; 
				} //若只能买下部分该物品
		idx++; //继续下一个物品
				cout<<ans<<endl; //输出
} 
   return 0;
}

你可能感兴趣的:(Algorithm,编程,C++,ACM,贪心算法)