uva 539 - The Settlers of Catan

  The Settlers of Catan 

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:


When the game ends, the player who built the longest road gains two extra victory points.


The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).


Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.


Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      \
o        o -- o        o -- o
               \      /
                o -- o

Input 

The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n ( ) and the number of edges m ( ). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output 

For each test case, print the length of the longest road on a single line.

Sample Input 

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output 

2
12
稀疏图,用邻接表存贮比较好,操作麻烦,改用数组代替了,回溯出最长路径,每次标记的是边而不是顶点
#include<stdio.h>
#include<string.h>
struct node
{int num,a[30];
}Node[30];
int visit[30],map[30][30],n,max; //map标记顶点间的边是否已遍历
void dfs(int pos,int num)
{int i;
 if (num>max) max=num;
 for (i=1;i<=Node[pos].num;i++)
 {if (map[pos][Node[pos].a[i]]==0)
  {map[pos][Node[pos].a[i]]=1;
   map[Node[pos].a[i]][pos]=1;
   dfs(Node[pos].a[i],num+1);
   map[pos][Node[pos].a[i]]=0;
   map[Node[pos].a[i]][pos]=0;
  }
 }
}
int main()
{int i,k,m,x,y;
 while (scanf("%d%d",&n,&m),n+m)
 {memset(Node,0,sizeof(Node));
  memset(visit,0,sizeof(visit));
  for (i=1;i<=m;i++)
  {scanf("%d%d",&x,&y);
   k=++Node[x].num; Node[x].a[k]=y;
   k=++Node[y].num; Node[y].a[k]=x;
   visit[x]=1;
   visit[y]=1;
  }
  max=0;
  for (i=0;i<n;i++)
  if (visit[i])
  {memset(map,0,sizeof(map));
   dfs(i,0);                   //开始随便找个点做起点,wrong了,应该穷举所有点作为起点~~~~(>_<)~~~~ 
  }
  printf("%d\n",max);
 }
 return 0;
}

你可能感兴趣的:(uva 539 - The Settlers of Catan)