POJ-1118-简单暴力题

Lining Up

Time Limit: 2000MS   Memory Limit: 32768K
Total Submissions: 22296   Accepted: 7040

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

Source

East Central North America 1994
 
 这道题当初是搜搜索题的时候找到的。可是一看发现可以直接暴力所以也就没有搜索了......

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct P
{
    int x,y;
}a[705];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&a[i].x,&a[i].y);
        int ans=1;
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                int sum=2;
                for(int k=j+1;k<n;k++)
                {
                    if((a[i].x-a[j].x)*(a[j].y-a[k].y)==(a[j].x-a[k].x)*(a[i].y-a[j].y))
                        sum++;
                }
                if(sum>ans) ans=sum;
            }
        }
        printf("%d\n",ans);
    }return 0;
}



你可能感兴趣的:(Algorithm,ACM,poj,Force,brute)