PAT A 1063. Set Similarity (25)

题目

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets.  Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case.  Each case first gives a positive integer N (<=50) which is the total number of sets.  Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109].  After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries.  Each query gives a pair of set numbers (the sets are numbered from 1 to N).  All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

 

即统计两个数串不重复的相同数字占总数字(不重复)的比重。

 

代码:

#include <iostream>
#include <cstdio>
#include <set>
using namespace std;

int main()
{
	set<int> sets[50];	//输入的sets,利用set直接排好序,且唯一了
	
	int n,m,i,j,temp;	//输入数据
	cin>>n;
	for(i=0;i<n;i++)
	{
		scanf("%d",&m);
		for(j=0;j<m;j++)
		{
			scanf("%d",&temp);
			sets[i].insert(temp);
		}
	}

	set<int>::iterator p1,p2;	//迭代器,用于扫描
	int k;
	int s1,s2;
	int nc,nt;	//nc,nt
	double rate;
	cin>>k;
	for(i=0;i<k;i++)
	{
		scanf("%d %d",&s1,&s2);
		p1=sets[s1-1].begin();	//从头开始扫描
		p2=sets[s2-1].begin();
		nc=0;
		nt=0;
		while(p1!=sets[s1-1].end()&&p2!=sets[s2-1].end())	//扫描到一个结束
		{
			if(*p1==*p2)	//相等
			{
				nc++;
				nt++;
				p1++;
				p2++;
			}
			else if(*p1<*p2)	//两种不等
			{
				nt++;
				p1++;
			}
			else
			{
				nt++;
				p2++;
			}
		}
		while(p1!=sets[s1-1].end())	//处理没结束的一个的剩余元素数量
		{
			p1++;
			nt++;
		}
		while(p2!=sets[s2-1].end())
		{
			p2++;
			nt++;
		}
		rate=double(nc)*100/nt;	//计算、输出
		printf("%0.1f%%\n",rate);
	}

	return 0;
}


 

 

 

 

你可能感兴趣的:(C++,pat)