hdu2616之简单搜索

Kill the monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 678    Accepted Submission(s): 482


Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it. 
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
 

Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 

Sample Input
   
   
   
   
3 100 10 20 45 89 5 40 3 100 10 20 45 90 5 40 3 100 10 20 45 84 5 40
 

Sample Output
   
   
   
   
3 2 -1
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10+10;
int s[MAX][2],n,m,sum;
bool mark[MAX];

void dfs(int num,int m){
	if(m<=0){
		sum=min(sum,num);
		return;
	}
	for(int i=0;i<n;++i){
		if(mark[i])continue;
		mark[i]=true;
		if(m<=s[i][1])dfs(num+1,m-2*s[i][0]);
		else dfs(num+1,m-s[i][0]);
		mark[i]=false;
	}
}

int main(){
	while(cin>>n>>m){
		for(int i=0;i<n;++i)cin>>s[i][0]>>s[i][1];
		sum=INF;
		memset(mark,false,sizeof mark);
		dfs(0,m);
		if(sum == INF)cout<<"-1"<<endl;
		else cout<<sum<<endl;
	}
	return 0;
}

你可能感兴趣的:(hdu2616之简单搜索)