hdu1698 Just a Hook (线段树功能:成段替换,总区间求和)

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1698


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

hdu1698 Just a Hook (线段树功能:成段替换,总区间求和)_第1张图片

Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
   
   
   
   
1 10 2 1 5 2 5 9 3

Sample Output
   
   
   
   
Case 1: The total value of the hook is 24.

题意:题意:有t组测试数据,n为钩子长度(1<=n<=100000),m为操作的次数。初始时,每个钩子的价值为1,操作由三个数字组成x,y,z表示把区间[x,y]的钩子变成的价值变成z(1代表铜,2银,3金)。

代码如下:

//hdu 1698
//线段树功能:update:成段替换 (由于只query一次总区间,所以可以直接输出1结点的信息)

#include <cstdio>
#include <algorithm>
using namespace std;
#define lson l , mid , rt << 1
#define rson mid + 1 , r , rt << 1 | 1

//lson和rson分辨表示结点的左儿子和右儿子
//rt表示当前子树的根(root),也就是当前所在的结点
const int maxn = 111111;
//maxn是题目给的最大区间,而节点数要开4倍,确切的来说节点数要开大于maxn的最小2x的两倍
int col[maxn<<2];//用来标记每个节点,为0则表示没有标记,否则为标记;
int sum[maxn<<2];//求和
void PushUp(int rt) //把当前结点的信息更新到父结点
{
	sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void PushDown(int rt,int len)//把当前结点的信息更新给儿子结点
{//对某一个区间进行改变,如果被标记了,在查询的时候就得把改变传给子节点,因为查询的并不一定是当前区间 
	if (col[rt]) //已经标记过,该区间被改变过 
	{
		col[rt<<1] = col[rt] ;//此处是替换,而非“+=”
		col[rt<<1|1] = col[rt];//此处是替换,而非“+=”
		/*此处用col[rt]乘以区间长度,不是col[rt<<1], 因为rt的儿子节点如果被多次标记,之前被标记时, 
          就已经对sum[rt<<1]更新过了。 
        */
		sum[rt<<1] = col[rt] * (len - (len >> 1));//此处是替换,而非“+=”
		sum[rt<<1|1] = col[rt] * (len >> 1);//此处是替换,而非“+=”
		col[rt] = 0;//将标记向儿子节点移动后,父节点的延迟标记去掉 
	}
}
void build(int l,int r,int rt)
{
	col[rt] = 0;//初始化为所有结点未被标记
	sum[rt] = 1;//初始化每个节点为1
	if (l == r)
	{
		//scanf("%d",&sum[rt]);
		return ;
	}
	int mid = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUp(rt);
}
void update(int L,int R,int c,int l,int r,int rt) 
{
	if (L <= l && r <= R)
	{
		col[rt] = c;
		sum[rt] = c * (r - l + 1);
		//更新代表某个区间的节点和,该节点不一定是叶子节点
		return ;
	}
	/*当要对被延迟标记过的这段区间的儿子节点进行更新时,先要将延迟标记向儿子节点移动 
    当然,如果一直没有对该段的儿子节点更新,延迟标记就不需要向儿子节点移动,这样就使 
    更新操作的时间复杂度仍为O(logn),也是使用延迟标记的原因。 
    */
	PushDown(rt , r - l + 1);//向下传递
	int mid = (l + r) >> 1;
	if (L <= mid)
		update(L , R , c , lson);//更新左儿子
	if (mid < R) 
		update(L , R , c , rson);//更新右儿子
	PushUp(rt);//向上传递更新和
}
/*int query(int L,int R,int l,int r,int rt)
{
	if (L <= l && r <= R)
	{
		return sum[rt];//要取rt子节点的值时,也要先把rt的延迟标记向下移动
	}
	PushDown(rt , r - l + 1);
	int mid = (l + r) >> 1;
	int ret = 0;
	if (L <= mid) 
		ret += query(L , R , lson);
	if (mid < R)
		ret += query(L , R , rson);
	return ret;
}*/
int main() 
{
	int N , Q ,T , K=0;
	int a , b , c;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&N,&Q);//N为节点数
		build(1 , N , 1);//建树
		while (Q--)//Q为询问次数
		{
		/*	char op[2];
			int a , b , c;
			scanf("%s",op);
			if (op[0] == 'Q') 
			{
				scanf("%d%d",&a,&b);
				printf("%lld\n",query(a , b , 1 , N , 1));
			}
			else
			{
				scanf("%d%d%d",&a,&b,&c);//c为区间a到b增加的值
				update(a , b , c , 1 , N , 1);
			}*/
			scanf("%d%d%d",&a,&b,&c);//c为区间a到b的改变值
			update(a , b , c , 1 , N , 1);
			
		}
		printf("Case %d: The total value of the hook is %d.\n",++K,sum[1]);
	}
	return 0;
}


你可能感兴趣的:(算法,线段树,HDU)