POJ 3461 Oulipo(简单KMP)

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17128   Accepted: 6892

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

                题目大意:给你两个串,求第一个串在第二个串出现的次数。

         解题思路:第一个串求next,然后用第二个匹配它。可以对比一下剪花布条这个题,区别就在于这个可以有重合的。

         题目地址:Oulipo

AC代码:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
char a[10005],p[1000005];
int next[10005],res,len1,len2;

void getnext()
{
     int i,j;
     next[0]=0; next[1]=0;
     for(i=1;i<len1;i++)
     {
          j=next[i];
          while(j&&a[i]!=a[j])
               j=next[j];
          if(a[i]==a[j])
               next[i+1]=j+1;
            else
               next[i+1]=0;
     }
}

void KMP()
{
     int i,j=0;
     for(i=0;i<len2;i++)
     {
          while(j&&p[i]!=a[j])
               j=next[j];
          if(p[i]==a[j])
               j++;
          if(j==len1)
          {
               j=next[j];   //匹配的时候可以重合.
               res++;   
          }
     }
}

int main()
{
     int n;
     cin>>n;
     while(n--)
     {
          scanf("%s%s",a,p);
          res=0;
          len1=strlen(a),len2=strlen(p);
          getnext();
          KMP();
          printf("%d\n",res);
     }
     return 0;
}


你可能感兴趣的:(KMP,poj,对比剪花布条)