hdu 1062 Text Reverse 字符串处理。简单水题

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18667    Accepted Submission(s): 7030


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
   
   
   
   
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
   
   
   
   
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 
没什么好说的。
代码:
#include <stdio.h>
#include <string.h>

int main()
{
	int t ;
	scanf("%d",&t);
	getchar() ;
	while(t--)
	{
		char line[1010] , temp[1010];
		gets(line) ;
		int len = strlen(line) , j = 0 ;
		for(int i = 0 ; i <= len ; ++i)
		{
			if(line[i] == ' '|| line[i] == '\0')
			{
				j = 0 ;
				strrev(temp) ;
				if(line[i] == ' ')
					printf("%s ",temp) ;
				else
					printf("%s",temp) ;
				temp[0]='\0' ;
			}
			else
			{
				temp[j++] = line[i] ;
				temp[j] = '\0' ;
			}
		}
		puts("") ;
	}
	return 0 ;
}

与君共勉

你可能感兴趣的:(text,reverse,字符串反转,HDU1062)