poj 3041-Asteroids

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X. 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
推荐指数:※※※
来源: http://poj.org/problem?id=3041
有一个网格,网格上有若干行星,一颗子弹可以打掉一行或一列行星。
现在要求使用最少的子弹,消灭行星。
行和列为二分图左右顶点,有连边的是行星,现在要求使用最少的点,覆盖所有的边(行星)。
注意:点的编号是从1开始的。
匈牙利算法: http://blog.csdn.net/zhu_liangwei/article/details/11488809
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
const int N=501;
int adj[N][N];
int find(int index,int *visited,int *link){
	int i;
	for(i=1;i<=adj[index][0];i++){
		if(visited[adj[index][i]]==false){
			visited[adj[index][i]]=true;
			if(-1==link[adj[index][i]]||find(link[adj[index][i]],visited,link)){
				link[adj[index][i]]=index;
				return true;
			}
		}
	}
	return false;
}
int hung(int n){
	int i,count=0;
	int visited[N],link[N];
	memset(link,-1,sizeof(link));
	for(i=1;i<=n;i++){
		memset(visited,0,sizeof(visited));
		if(find(i,visited,link)==true)
			count++;
	}
	return count;
}
int main()
{
	int n,k,i;
	scanf("%d%d",&n,&k);
		memset(adj,0,sizeof(adj));
		for(i=0;i<k;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			adj[a][++adj[a][0]]=b;
		}
		int times=hung(n);
		printf("%d\n",times);
	return 0;
}


你可能感兴趣的:(poj 3041-Asteroids)