hdu 1789 贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3621    Accepted Submission(s): 2086


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
   
   
   
   
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
   
   
   
   
0 3 5
 

Author
lcy
 

Source
2007省赛集训队练习赛(10)_以此感谢DOOMIII
贪心  这道题貌似有很多解法~~
将数据按分数从大到小排序,每次取最大分数的将其安排在截至期限的最后一天,如果此天已安排,则一直向前一天安排,直到不能安排,则加入s,,代码如下:
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
struct node
{
    int deline;
    int score;
};
node a[1005];
bool cmp(node lh,node rh)
{
    return lh.score>rh.score;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int i;
        for(i=0;i<n;i++)
            scanf("%d",&a[i].deline);
        for(i=0;i<n;i++)
            scanf("%d",&a[i].score);
        sort(a,a+n,cmp);
        bool b[1005];
        memset(b,false,sizeof(b));
        int s=0;
        for(i=0;i<n;i++)
        {
            int j=a[i].deline+1;
            while(--j)
            {
                if(b[j]==0)
                {
                    b[j]=1;
                    break;
                }
                else
                {
                    continue;
                }
            }
            if(j==0)
                s=s+a[i].score;
        }
        printf("%d\n",s);
    }
    return 0;
}

还担心了下效率,没想到过了~~~

你可能感兴趣的:(hdu 1789 贪心)