Longest Ordered Subsequence
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 35745 |
|
Accepted: 15685 |
Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4
第一次做这样的题,推出公式后就A了,跟hdu 1087差不多,一个事实求最大上升子序列,一个是求最长上升子序列。
状态转移公式:dp[i] = max(dp[j]+1,dp[i])(Ai>Aj&&j<i);i表示以Ai结尾的最长上升子序列。
没啥好说的,直接代码:
#include <stdio.h>
#define INF 100000000
#define MAX 1010
int max(int a, int b)
{
return a>b?a:b ;
}
int main()
{
int n , dp[MAX] , num[MAX];
while(~scanf("%d",&n))
{
for(int i = 1 ; i <= n ; ++i)
{
scanf("%d",&num[i]);
dp[i] = 0 ;
}
dp[0] = 0 ;
int ans = -INF ;
for(int i = 1 ; i <= n ; ++i)
{
dp[i] = 1 ;
for(int j = 1 ; j <= i ; ++j)
{
if(num[i]>num[j])
dp[i] = max(dp[j]+1,dp[i]);
}
ans = max(dp[i],ans) ;
}
printf("%d\n",ans) ;
}
return 0 ;
}