hdoj 5112 A Curious Matt 【签到题】

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 931    Accepted Submission(s): 487


Problem Description
There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 10 6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 

Sample Input
   
   
   
   
2 3 2 2 1 1 3 4 3 0 3 1 5 2 0
 

Sample Output
   
   
   
   
Case #1: 2.00 Case #2: 5.00
Hint
In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.
 
题意:给你一个人 在一些时刻的位置,让你求出这个人所能达到的最大速度。


水题。。。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#define MAXN 10000+10
using namespace std;
struct rec
{
    int pos, time;
};
bool cmp(rec a, rec b)
{
    return a.time < b.time;
}
rec num[MAXN];
int main()
{
    int t, N;
    int k = 1;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &N);
        for(int i = 0; i < N; i++)
            scanf("%d%d", &num[i].time, &num[i].pos);
        sort(num, num+N, cmp);
        double ans = 0;
        for(int i = 1; i < N; i++)
        {
            double speed = (num[i].pos - num[i-1].pos) * 1.0 / (num[i].time - num[i-1].time);
            ans = max(ans, fabs(speed));
        }
        printf("Case #%d: %.2lf\n", k++, ans);
    }
    return 0;
}


你可能感兴趣的:(hdoj 5112 A Curious Matt 【签到题】)